Trail Balance Report Issue in AX 2012

This question is answered

one user is facing below error message while accessing trail balance report in GL->Reports->Transactions->Grouping->Detailed trail Blance and GL->Reports->Transactions->Grouping->Summary trail Blance -

Error Executing Code : Map(object), method createFromXML called with invalid parameters. Stack trace (c)(\Classes\Map\CreateFromXML

Error Executing Code : Map(object), method createFromXML called with invalid parameters.

Initially he was able to access the same. Now he doesnt but other users are still able to view that report. User is having system administrator role.

If anybody can suggest solution, it will be appreciated.

Verified Answer
  • Hi Pankaj,

    For us, this was happening because the user has select some wierd query parameters for filtering. AX stores the queries which user had last used in all the forms. These filters are applied when  the user opens form again. To fix this, you need to delete the corresponding record from SysLastValue table.  

    You will require a developer to help you in this. Below are the steps I followed to resolve this:

    1) Press Ctrl+D to open AOT

    2) Navigate to the path: Forms>SysLastValue>DataSources>SysLastValue

    3) Right click on SysLastValue Table > Addins > Table Browser

     *This will open SysLastValue Table..we did this because the table is not directly accessible.

    4) Now Filter the list of queries by the criteria: [elementName = "*LedgerTrialBalance*"] and UserID = <user id which is getting error>

    5) Select all the records and delete them using Alt+F9

    You need the user to close AX before performing above steps. Taking a backup would be recommended.

    Best Regards,

    Michael Brown

  • Thanks Michael...It worked..Thank you very much

All Replies
  • Hi Pankaj,

    For us, this was happening because the user has select some wierd query parameters for filtering. AX stores the queries which user had last used in all the forms. These filters are applied when  the user opens form again. To fix this, you need to delete the corresponding record from SysLastValue table.  

    You will require a developer to help you in this. Below are the steps I followed to resolve this:

    1) Press Ctrl+D to open AOT

    2) Navigate to the path: Forms>SysLastValue>DataSources>SysLastValue

    3) Right click on SysLastValue Table > Addins > Table Browser

     *This will open SysLastValue Table..we did this because the table is not directly accessible.

    4) Now Filter the list of queries by the criteria: [elementName = "*LedgerTrialBalance*"] and UserID = <user id which is getting error>

    5) Select all the records and delete them using Alt+F9

    You need the user to close AX before performing above steps. Taking a backup would be recommended.

    Best Regards,

    Michael Brown

  • Thanks Michael...It worked..Thank you very much