Error When open Data Import \ Export parameters screen

Question Status

Suggested Answer
soha mostafa asked a question on 11 Jul 2013 1:07 AM

when open Data Import \ Export  parameters screen system raises the following error:

Assembly containing type Microsoft.Dynamics.AX.DMF.ServiceProxy.DmfEntityProxy is not referenced

object CLR object could not be created

and this issue appeared only when database server is not the same as AOS server.

 

Reply
André Arnaud de Calavon responded on 11 Jul 2013 7:06 AM

Hi Soha,

Check if all components are installed and with the correct permissions.

Take a careful look at the next page: technet.microsoft.com/.../jj225595.aspx

I think a dll is missing in a certain directory.

Reply
soha mostafa responded on 16 Jul 2013 1:21 AM

I followed the steps in technet.microsoft.com/.../jj225595.aspx

And i installed DMF on Many servers and its works successfully but all these servers contain AOS service and AX database at the same server.

My case now I installed DMF on AOS server and DB on another server.

Reply
Tom Zak2 responded on 4 Jun 2014 6:49 AM

I am having this same problem as well on AX 2012 R3. The DIXF service was installed on the SQL server and the AOS components on the AOS.

standard setup according to the installation guide of April 2014.

Does anyone have a solution?

Reply
André Arnaud de Calavon responded on 4 Jun 2014 7:03 AM

Hi Tom,

You did not mentioned you installed the Client components. On the machine where you run the client you need also install the DIXF client components.

Reply
Suggested Answer
Francisco Silva responded on 4 Jun 2014 9:53 AM

Hello!

For AX2012 R2 CU7, have you installed the KB2859549? This KB must be installed before you stard the setup from CU7.

For AX2012 R3, have you configured the DIEF servisse account as a member of DIEF security group into the same server and restarted the server?

Here you can find how to install DIEF for AX2012 R2:

fsilvajunior.blogspot.com.br/.../instacao-do-data-import-export.html

And here you can find how to install DIEF on AX2012 R3:

technet.microsoft.com/.../dn720760.aspx

Reply
Suggested Answer
Rudhra Kumar responded on 4 Jun 2014 10:13 AM

Hi ,

Please navigate to the Reference node in AOT, right click add reference and browse the location were the Microsoft.Dynamics.AX.DMF.ServiceProxy.DmfEntityProxy dll is located then apply ok then restart the AOS service and check.

Also copy the Microsoft.Dynamics.AX.DMF.ServiceProxy.DmfEntityProxy dll and place into the directory were the error pops up and make sure it is available in both servers(AOS and DB) directories.

Reply
Suggested Answer
Tom Zak2 responded on 4 Jun 2014 12:15 PM

The solution was to restart the AOS. Then the problem is gone. That step is missing from the installation guide.

Reply
Suggested Answer
Nitesh Ranjan responded on 26 Aug 2014 12:23 AM

I also got this issue resolved by restarting the server,

so I also recommend restart the AOS step should be there

Reply
Suggested Answer
Surender Singh responded on 27 Aug 2014 5:18 AM

Hi

1. Stop the AOS

2. Delete all files in xppl folder or may be you can take backup of them.

3. Restart the AOS (It will take some time as it will re-generate the files in xppl folder).

Thats how I resolved this error.

Reply
Dick Wenning responded on 27 Aug 2014 6:43 AM

While you use the Data Import/Export Framework, you might receive the following error message:

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException

Verify that the following files are present in the C:\Program Files (x86)\Microsoft Dynamics AX\60\Server\Bin folder on the server that is running the AOS instance:

DMFConfig.xml

DMFClientConfig.xml

Microsoft.Dynamics.AX.DMF.ServiceProxy.dll.config

Resolution

Copy the .xml and the config files from the installation location (C:\Program Files\Microsoft Dynamics AX 2012 Data Import Export Framework Server Component) to the C:\Program Files (x86)\Microsoft Dynamics AX\60\Server\Bin folder on the server that is running the AOS instance.

Reply
Suggested Answer
UMESH PANDIT responded on 18 Nov 2014 7:31 AM

Hi Soha,

1. Log on to AOS server> Stop the AOS

2. Locate Xppl Folder, Delete all files in xppl folder (IMP: backup them first)

3. Restart the AOS (It will take some time as it will re-generate the files in xppl folder).

This worked for me.

Reply
Suggested Answer
Umair Qaisar responded on 19 Mar 2015 11:48 AM

This fixed my issue. Thanks.

Reply
Torkia responded on 24 Jul 2015 11:27 AM

Hello,

I have the same issue.

I'm using AX2012 R3. Please, where I can find the folder XPPL?

 

Thanks

Reply
Martin Dráb responded on 24 Jul 2015 11:40 AM

I think he meant XppIL folder, the folder containing CIL assemblies generated from X++. The default path is C:\Program Files\Microsoft Dynamics AX\60\Server\{instance name}\bin\XppIL\.

Reply
Ricardo Garcia responded on 4 Dec 2015 7:44 AM

Thank! Rudhra kumar your tip worked in my case!

Reply
Suggested Answer
Francisco Silva responded on 4 Jun 2014 9:53 AM

Hello!

For AX2012 R2 CU7, have you installed the KB2859549? This KB must be installed before you stard the setup from CU7.

For AX2012 R3, have you configured the DIEF servisse account as a member of DIEF security group into the same server and restarted the server?

Here you can find how to install DIEF for AX2012 R2:

fsilvajunior.blogspot.com.br/.../instacao-do-data-import-export.html

And here you can find how to install DIEF on AX2012 R3:

technet.microsoft.com/.../dn720760.aspx

Reply
Suggested Answer
Rudhra Kumar responded on 4 Jun 2014 10:13 AM

Hi ,

Please navigate to the Reference node in AOT, right click add reference and browse the location were the Microsoft.Dynamics.AX.DMF.ServiceProxy.DmfEntityProxy dll is located then apply ok then restart the AOS service and check.

Also copy the Microsoft.Dynamics.AX.DMF.ServiceProxy.DmfEntityProxy dll and place into the directory were the error pops up and make sure it is available in both servers(AOS and DB) directories.

Reply
Suggested Answer
Tom Zak2 responded on 4 Jun 2014 12:15 PM

The solution was to restart the AOS. Then the problem is gone. That step is missing from the installation guide.

Reply
Suggested Answer
Nitesh Ranjan responded on 26 Aug 2014 12:23 AM

I also got this issue resolved by restarting the server,

so I also recommend restart the AOS step should be there

Reply
Suggested Answer
Surender Singh responded on 27 Aug 2014 5:18 AM

Hi

1. Stop the AOS

2. Delete all files in xppl folder or may be you can take backup of them.

3. Restart the AOS (It will take some time as it will re-generate the files in xppl folder).

Thats how I resolved this error.

Reply
Suggested Answer
UMESH PANDIT responded on 18 Nov 2014 7:31 AM

Hi Soha,

1. Log on to AOS server> Stop the AOS

2. Locate Xppl Folder, Delete all files in xppl folder (IMP: backup them first)

3. Restart the AOS (It will take some time as it will re-generate the files in xppl folder).

This worked for me.

Reply
Suggested Answer
Umair Qaisar responded on 19 Mar 2015 11:48 AM

This fixed my issue. Thanks.

Reply
Suggested Answer
Mohd Shah responded on 14 Aug 2017 2:05 AM

In my case, Integration service and analysis service were running with NT’ Services, I changed with AOS service and DIFX service.

Now all following services are running with same credential.

Integration service,

Analysis service

AOS service

DIFX service

Reply