SBX - Search With Button

SBX - Forum Post Title

Prerequisite check: WSDL URI not accessible

Microsoft Dynamics AX Forum

Ruttiger asked a question on 29 Jul 2013 4:03 AM

Question Status

Verified

Hi,

After upgrading AX2012 R2 with CU1 and a kernel Hotfix -so that the current system version is 6.2.1000.693- and after running the initialization checklist, I had to reinstall the Enterprise Portal component to resolve some issues with it.

When I start the Microsoft Dynamics AX Setup trying to install de Enterprise Portal component, I get an error at the prerequisite check:

Performing a service status check for prerequisite 'Application Object Server (AOS) Services WSDL URI accessible'. - Check failed.

When I click on the "Error"link I get the message:

"Resolution: Attempt to access the WSDL port manually by entering the URI http://<SERVER>:/DynamicsAx/Services/MetadataService. ..."

It seems that the port (8101) is missing in the URI the prerequisite checker is trying to access.

If I enter the URI http://<SERVER>:8101/DynamicsAx/Services/MetadataService in the browser it works without any problem.

How can I solve this error to continue with the installation of the Enterprise Portal?

- I have only one AOS instance in this server and more than one client configuration file so I’ve regenerated the WCF configuration under the Connection tab from Client Configuration Utility.

- I have restarted the AOS but this has made no difference, the error still persists.

- I’ve check the Registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dynamics\6.0\Configuration\Original (installed configuration) & SetupProperties and I have verified the port number of the wdsl entry is 8101.

Regards

Reply
Asser Fahrenholz responded on 5 Aug 2013 4:18 AM
My Badges

I've got the same problem - did you reach a solution ?

Reply
Ruttiger responded on 5 Aug 2013 4:33 AM

At the moment I still have the problem.

If I get to find the solution I'll post it here but any help is welcome.

Reply
Surya Koundinya responded on 19 Sep 2013 1:19 PM
My Badges
Verified Answer

The rootcause of this issue is, you must have installed .NET Business Connector to resolve some 32/64 bit InstallPath issue.

and The Default Client configuration in this server points to blank WSDL port.

To fix this issue:

1.Open Client configuration.

2.Create a new Configuration for AX and BusinessConnector. Ensure the WSDL port is set to the correct value [Default : 8101].

3.Perform Refresh Configuration to generate WCF Settings.

4.Exit the setup and run it again

Regards

Surya Koundinya

Reply
Sankalp responded on 21 Oct 2014 12:59 PM

 , Thank you for the solution. This worked perfect for me.

Reply
Jahir responded on 6 Apr 2016 7:57 AM
My Badges

Thanks this is very helpful to solve the issue.

Reply
robertthomas responded on 19 Apr 2016 6:40 PM

It definitely looks like there is a problem with your WSDL port.   If you are still having an issue you can can check out this article

Robert T.

Reply
Anucha Maneeyotin responded on 25 Jul 2017 11:20 PM
My Badges

To fix this issue:

1.Open Client configuration.

2.Create a new Configuration for AX and BusinessConnector. Ensure the WSDL port is set to the correct value [Default : 8101].

3.Perform Refresh Configuration to generate WCF Settings.

4.Restart AOS

Reply
Surya Koundinya responded on 19 Sep 2013 1:19 PM
My Badges
Verified Answer

The rootcause of this issue is, you must have installed .NET Business Connector to resolve some 32/64 bit InstallPath issue.

and The Default Client configuration in this server points to blank WSDL port.

To fix this issue:

1.Open Client configuration.

2.Create a new Configuration for AX and BusinessConnector. Ensure the WSDL port is set to the correct value [Default : 8101].

3.Perform Refresh Configuration to generate WCF Settings.

4.Exit the setup and run it again

Regards

Surya Koundinya

Reply

SBX - Two Col Forum

SBX - Migrated JS