Using terminals to log employees in and out of jobs.

Question Status

Brad-Man asked a question on 11 Sep 2013 1:40 PM

Hi everyone.

I am a newebie at Dynamics AX.

I am a Systems Administrator and my company is in the final stages of preparing to go live with Dynamics AX 2012.

I have no problem setting up users and adding roles, as long as I know what is needed.

I don't actually do any work in AX from a production standpoint and have not been involved in anything more that setting the machine up installing the operating system and SQL Server, along with RDP Session Host on the machine, and of course setting up security/permisions.

I am using Wyse terminals and RDP to automatically get into Dynamics AX (I have seven of these and may wind up using actual computers for other stations that our shop floor people will use to denote time spent on each job..

The project leader wants the RDP session to automatically go to the Production Control/Job Registration Screen when the session opens up.

I have tried what apparently works from a command line that he gave me with no luck.

All terminals will use the same login, so I realize that it will stay on that screen if disconnected and then connects again.

I of course want to provide the project manager with exactly what he wants and set up a role or pass parameters to Dynamics AX to go to that screen.

Is this possible?

If so, if you would kindly point me in the right direction I would appreciate it - There is WAY too much to wade through to find the tidbits I need....



Dominic Lee responded on 12 Sep 2013 2:27 AM

This post should help:

Good luck

Brad-Man responded on 13 Sep 2013 10:22 AM

I set up remote desktop with ax32.exe "-startupcmd=startupelementaction_\Menu&Items\Display\JmgRegistrationJobQueue" in the run program and therun program in directory path yesterday and it worked.

Today, even using this command in Powershell I get an error message in Dynamics AX "access rights are not sufficient to use this function"

This worked yesterday too.

What is going on?

Brad-Man responded on 13 Sep 2013 1:23 PM

I figured it out...

I set up 2 repmote Deskto Sessions into the Dynamics machine one w/my id and one as a "timeclock" id.

w/my ID I was able to use the command line to get into the form automatically.

Wiith the "timeclcok" ID i got into Dynamics but got an error box saying the error stated above.

I am of course a Systems administrator in the domain and for AX so this explains it.

Now however, I am trying to figure out how to limit the roles that the proper access would give for the "timeclock" ID...