Question Status

Verified
fred666 asked a question on 2 Sep 2014 11:10 AM

Hello.

I try create virtual table, I log off all the sessions less mine, I have the role sys admin but shows me the messagge:

A virtual company can be created only by an administrator who is connected to a single Application Object Server (AOS) instance. No other client connections or AOS instances can be running

somebady helpe me!

best regards

Reply
Denis Macchinetti responded on 2 Sep 2014 11:41 AM

Hi Fred

If you go through the Online users form, you are able to see other user connections?

Also, restart the AOS and try again

Thanks & Regards

Denis Macchinetti

Technical Architect

Respect the provided answers from other community members. Don't provide or do not copy the same answer to the same thread. Additional insights are welcome!

Reply
André Arnaud de Calavon responded on 2 Sep 2014 11:46 AM

Hi Fred,

In addition on the reply from Denis: if you have multiple partitions in AX and the online users from shows that you are the only user and you get this.error, logon in the other partitions as well. Recently I have encountered a scenario where not all the online users were presented. 

kind regards,

André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

Reply
fred666 responded on 2 Sep 2014 11:49 AM

Hi Denis, Thaks for your answer.

Yes, I do, and I end all the sessions.

I tried restarting the AOS and a have the same issue.

best regards

Reply
Verified Answer
Denis Macchinetti responded on 2 Sep 2014 12:22 PM

Hi Fred

I suggest you to :

1- Stop AOS

2- Backup the AX Databases

3- Go through SQL side and running the follow queries on your AX database :

Delete from SYSCLIENTSESSIONS

delete FROM SYSSERVERSESSIONS

4- Start AOS

5- Try again

Thanks & Regards

Denis Macchinetti

Technical Architect

Respect the provided answers from other community members. Don't provide or do not copy the same answer to the same thread. Additional insights are welcome!

Reply
fred666 responded on 2 Sep 2014 12:29 PM

Thanks, I will try it.

Reply
Suggested Answer
fred666 responded on 3 Sep 2014 3:34 PM

thanks Denis your solution works.

Best  regards

Reply
Verified Answer
Denis Macchinetti responded on 2 Sep 2014 12:22 PM

Hi Fred

I suggest you to :

1- Stop AOS

2- Backup the AX Databases

3- Go through SQL side and running the follow queries on your AX database :

Delete from SYSCLIENTSESSIONS

delete FROM SYSSERVERSESSIONS

4- Start AOS

5- Try again

Thanks & Regards

Denis Macchinetti

Technical Architect

Respect the provided answers from other community members. Don't provide or do not copy the same answer to the same thread. Additional insights are welcome!

Reply
Suggested Answer
fred666 responded on 3 Sep 2014 3:34 PM

thanks Denis your solution works.

Best  regards

Reply