Question Status

Verified
Samy123 asked a question on 12 Mar 2015 2:11 PM

Hi,

I ran into a problem when I needed to add two fields WorkerSalesRespobsible and WorkerSalesTaker from SalesTable to an existing grid in SalesLineOpenOrder form in AOT. When I dragged and dropped the fields from the forms DataSource (SalesTable) it looks like this in AOT.

When I compiled and open the form it is not showing any records under these two fields. I queried the DB and data is there in these two fields and I think datasouces are also setup properly. Am I missing something here ?

Reply
Martin Dráb responded on 12 Mar 2015 2:15 PM

Is your SalesTable data source inner-joined with the SalesLine datasource?

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Samy123 responded on 12 Mar 2015 2:36 PM

Hi Martin,

I have a relation in the SalesTable that says SalesTable.SalesId == SalesLine.SalesId are we looking for this ? or I need to look somewhere else ?

Reply
Verified Answer
Martin Dráb responded on 12 Mar 2015 3:00 PM

No, that just says how the tables will be linked if you decide to link them.

Please look at How to: Join Data Sources for a Form.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Samy123 responded on 12 Mar 2015 3:16 PM

Thanks Martin.

I join was there but the LinkType was delayed I changed it to innerjoin and did the trick :) So I think this is nothing to do with ReferenceGroup control right ?

Reply
Martin Dráb responded on 12 Mar 2015 4:46 PM

That's correct. The reference group correctly replaced RecId with worker's name, but because of the type of link, you had only one SalesTable loaded at any time.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply
Verified Answer
Martin Dráb responded on 12 Mar 2015 3:00 PM

No, that just says how the tables will be linked if you decide to link them.

Please look at How to: Join Data Sources for a Form.

Martin "Goshoom" Dráb | Freelancer | Goshoom.NET Dev Blog

Reply