SBX - Search With Button

SBX - Forum Post Title

Cannot edit a record in Net requirements (ReqTrans). An update conflict occurred due to another user process deleting the record or changing one or more fields in the record

Microsoft Dynamics AX Forum

Rajkumar Gunasekaran asked a question on 20 Apr 2016 3:57 AM
My Badges

Question Status

Suggested Answer

Dears,

I am getting the below error when i am run  production order scheduling

Error Message:

Cannot edit a record in Net requirements (ReqTrans).
An update conflict occurred due to another user process deleting the record or changing one or more fields in the record

 

Please help me to solve this issue.

Thanks

Rajkumar

Reply
Dick Wenning responded on 20 Apr 2016 5:06 AM
My Badges

is this default AX? or customized?

Reply
Rajkumar Gunasekaran responded on 20 Apr 2016 5:25 AM
My Badges

It is default AX 2012, No customization.

Thanks

Rajkumar

Reply
Sree Potturi responded on 20 Apr 2016 5:43 AM
My Badges

Do you have any MRP jobs running as batch process ? Check to see if the batch job ended or still in executing status ?

You can also check the database to see for any dead locks present by running sp_who2

Reply
Rajkumar Gunasekaran responded on 20 Apr 2016 6:03 AM
My Badges

No MRP, No batch process production.

Thanks

Rajkumar

Reply
Dick Wenning responded on 20 Apr 2016 6:05 AM
My Badges

is the MRP running at this moment?

LCS MS

Issue 3647619Cannot edit a record in Net requirements (ReqTrans) during MRP or opening the Net Requirements window

Product and version

Microsoft Dynamics AX 2012 R2

RESOLUTION

Will not be fixed

PROBLEM

You cannot edit a record in Net requirements (ReqTrans) during MRP or opening the Net Requirements window.

REMARKS

Microsoft has evaluated this issue, and will not be issuing a fix at this time.

Reply
Sree Potturi responded on 20 Apr 2016 6:05 AM
My Badges

ok good. You need to Sync the reqTrans table and see if the error goes away. As i mentioned earlier see if there any locks on ReqTrans that is holding this transaction.

Reply
Rajkumar Gunasekaran responded on 20 Apr 2016 7:36 AM
My Badges

I have done Sync the ReqTrans table, But still sames issue. Please tell me, where can i check the locks on ReqTrans table

Thanks

Rajkumar

Reply
Sree Potturi responded on 21 Apr 2016 5:21 AM
My Badges

You need to check in SQL Server through management Studio . Run the command sp_who2 which can give which transaction is blocked by which transaction. Also you can use Activity monitor from SQL Management studio to see which Query is blocking.

Reply
Fredrik Sætre responded on 22 Apr 2016 1:07 PM
My Badges
Suggested Answer

Go to Master planning and under periodic, find the unfinished schedules and see if there is anything running. If so, cancel and delete it.

If that does not work.... Purge the ReqTrans table, recalculate BOM levels and run production planning again.

Reply
Adam Chronister responded on 22 Apr 2016 4:25 PM
My Badges
Suggested Answer

You may want to try this out. I've had to manually change some settings on the reqtrans table before

http://axcalated.blogspot.com/2015/03/firming-planned-order-returns-error.html

Reply
Rajkumar Gunasekaran responded on 25 Apr 2016 7:08 AM
My Badges

Hi Adam,

I have followed step#1 and then it is accepting to run the scheduling wihtout any error.

Step 1. Update ReqTrans

Go to \Tables\ReqTrans

Change the property OccEnabled from "yes" to "no"

I need to change it back or no need.

If i am not changing to back what it is doing business wise

Thanks

Rajkumar

Reply
Marek Novotný responded on 2 Dec 2016 2:54 AM
My Badges

Hello Rajkumar,

did you solve this issue? We are facing same problem. We try change OccEnable on TEST environment and it helps, but after consultation with our devs, this is not good option. It could cause long running MRP and other performance issues. I also check other things mentioned in this thread.

Will be glad for any furhter info.

Thanks

Marek

Reply
Ahmed Siliem responded on 30 Dec 2018 8:10 AM
My Badges
Suggested Answer

Hi everybody,

in AX 2012 R3 CU13, it just requires to go to Master planning/Periodic/Plans and select "Delete Plane".

Then, normally, go to run the Master Scheduling again and make sure to select "Regeneration" under Principle.

Hope this fixes your issue.

Reply
Fredrik Sætre responded on 22 Apr 2016 1:07 PM
My Badges
Suggested Answer

Go to Master planning and under periodic, find the unfinished schedules and see if there is anything running. If so, cancel and delete it.

If that does not work.... Purge the ReqTrans table, recalculate BOM levels and run production planning again.

Reply
Adam Chronister responded on 22 Apr 2016 4:25 PM
My Badges
Suggested Answer

You may want to try this out. I've had to manually change some settings on the reqtrans table before

http://axcalated.blogspot.com/2015/03/firming-planned-order-returns-error.html

Reply
Ahmed Siliem responded on 30 Dec 2018 8:10 AM
My Badges
Suggested Answer

Hi everybody,

in AX 2012 R3 CU13, it just requires to go to Master planning/Periodic/Plans and select "Delete Plane".

Then, normally, go to run the Master Scheduling again and make sure to select "Regeneration" under Principle.

Hope this fixes your issue.

Reply

SBX - Two Col Forum

SBX - Migrated JS