SBX - Search With Button

SBX - Forum Post Title

Item Has No Active Version Setup And Is Therefore Blocked For Transactions

Microsoft Dynamics AX Forum

Simon Turner asked a question on 14 Jun 2018 9:09 AM
My Badges

Question Status

Suggested Answer

Hi

I am trying to create a works order.

I select the part and select Version A (we have versions A and B).

It then asks me to Insert The Active Versions for bill of materials and route. I answer Yes.

Then get the message "Item *** Has No Active Version Setup And Is Therefore Blocked For Transactions"

Any ideas?

Thank you

Reply
Simon Turner responded on 15 Jun 2018 4:35 AM
My Badges

Hi

As anyone any ideas on this one?

Thank you

Simon

Reply
Crispin John Augustine responded on 15 Jun 2018 4:42 AM
My Badges

Can you go to the BOM lines for this item, and click ono the "Activation" button?.

Create the Production order after doing this. (important because, PRodBOM should be initialized with activated version)

Reply
Simon Turner responded on 15 Jun 2018 7:08 AM
My Badges

Hi

Yes all active like you suggest

But still get the same error when creating a works order

Thank you

Simon

Reply
Crispin John Augustine responded on 15 Jun 2018 7:37 AM
My Badges

Is the Route also activated, before creating the order?

Reply
Simon Turner responded on 15 Jun 2018 8:22 AM
My Badges

Yes it is.

Thanks

Simon

Reply
Daxer Persson responded on 15 Jun 2018 8:31 AM
My Badges
Suggested Answer

Looks like the BOM/route is not approved/active for the site, where you're trying to create a Works order.

Reply
Simon Turner responded on 15 Jun 2018 8:46 AM
My Badges

It is failing on this check

Reply
Crispin John Augustine responded on 15 Jun 2018 8:54 AM
My Badges

That Looks like a custom method?

Reply
Daxer Persson responded on 15 Jun 2018 8:54 AM
My Badges

hmm. On the default order settings of the item, it's possible to "Stopped" for purchase, sales as well as inventory transactions e.g. for the sites.

Maybe this happened?

Reply
Simon Turner responded on 15 Jun 2018 9:00 AM
My Badges

Hi Daxer

No, all these are unticked

regards

Simon

Reply
Simon Turner responded on 15 Jun 2018 9:02 AM
My Badges

Hi Crispin

A possible problem with a customerization?

Regards

Simon

Reply
Crispin John Augustine responded on 15 Jun 2018 9:23 AM
My Badges

To me, at first look, it appears as a customized method. So, yes (unless you prove, it is a Standard method)

Reply
Simon Turner responded on 15 Jun 2018 9:58 AM
My Badges

I have resolved this issue finally!

The problem was that in Product Information Management > Common > Product > Product Masters

Under Engineering versions, I put a date in the effective to date. This now allows me to create a works order.

Thank you

Simon

Reply
Simon Turner responded on 15 Jun 2018 10:07 AM
My Badges

Please ignore the above.

I have since found you do not need to have an effective date.

The problem was an old version had an effective date of blank but a time not equal to 00:00:00

When there is something in this time with a blank date e.g 00:00:01, it will come up with the error

Thank you

Simon

Reply
Daxer Persson responded on 15 Jun 2018 8:31 AM
My Badges
Suggested Answer

Looks like the BOM/route is not approved/active for the site, where you're trying to create a Works order.

Reply

SBX - Two Col Forum

SBX - Migrated JS