SBX - Search With Button

SBX - Forum Post Title

How to install AX2012 R3 with Visual studio(for SSRS reports)

Microsoft Dynamics AX Forum

Akbarpasha asked a question on 11 Oct 2018 2:25 AM

Question Status

Verified

Hi All,

Please advise me how to install How to install AX2012 R3 with Visual studio(for SSRS reports), what are the prerequisites for the machine, as we want to install SQL in one machine and AX in another, 

Which version of SQL required?

Which version of Visual studio required?

Which version of SQL Server Data Tools required?

we found some of the links and PDF files for prerequisites, that looks very complex, can any one please provide simple steps for AX , SQL and SSRS reports installation.

It would be great help for me.

Regards,

Akbar

Reply
Suggested Answer

You will find all the information you need in Dynamics AX 2012 System Requirements document: www.microsoft.com/.../details.aspx

Here is Dynamics AX 2012 installation guide: www.microsoft.com/.../details.aspx

If you don't want to install everything yourself, you can also deploy fully configured dev environments from Lifecycle Services to your Azure subscription. Or download a demo VHD, which contains all dev tools as well.

Please see more info here: docs.microsoft.com/.../deploy-2012-r3-azure-lcs

Reply
Raheel Khan responded on 11 Oct 2018 2:40 AM
My Badges
Suggested Answer

Salam!

Dear Akbar,

Hope you are fine!

You must read Microsoft Dynamics AX 2012 System Requirements for successful AX implementation, if you don't want to read it out just go for this link and take a basic prerequisites mentioned below link.

http://dynamics-ax.blogspot.com/2012/11/microsoft-dynamics-ax-2012-system.html

Reply
Akbarpasha responded on 11 Oct 2018 9:01 AM

Thanks Nikolaos and Raheel...

What will be the sequence to install all applications...means do we need to follow any sequence while installation or we can install any application first....

As per our understanding order will be

1. SQL server

2. Visual studio

3. AX

Please correct me if i am wrong.

Regards,

Akbar

Reply
Verified Answer

You need the SQL Server before you can install AX, and you need VS before you can install AX VS tools, so your plan sounds correct.

Please also understand that AX has multiple components which might need to be installed in specific sequence.

Reply
Raheel Khan responded on 11 Oct 2018 11:53 AM
My Badges
Verified Answer

1- SQL Server

2- AOS

3- Visual studio

4-AX VS tools

5-Client

Please mark answers as suggested if these are helpful for you

Reply
Akbarpasha responded on 11 Oct 2018 8:01 PM

Thank you very much Nikolaos and Raheel,

We have configured one machine where we have installed SQL in another server, 

we have started like :

1 . SQL 2016

2. AX 2012 R3

based on requirement (SSRS reports) we have installed Visual studio 2013 , but the reports are not getting edited , it is showing the error : even we have installed VS2013 SSDT tools.

Any suggestion please.

Reply
Raheel Khan responded on 11 Oct 2018 11:53 PM
My Badges
Suggested Answer

Dear Akbar,

Have you installed Developer Tool (VS Tools) on your AOS where you want to edit report?

Reply
Akbarpasha responded on 12 Oct 2018 12:03 AM

Yes Raheel...we have installed developer tools in AX server... while editing report getting that error.

Reply
Raheel Khan responded on 12 Oct 2018 12:12 AM
My Badges
Verified Answer

What about this?

Reference: http://msdynamicsaxtips.blogspot.com/2015/02/unable-to-preview-report-install.html

After that restart SQL and AOS Services, If issue remain same, then I will recommend you to install same version of all of these applications like:

 AX: AX 2012 R3
OS: Windows Server 2012
SQL: SQL 2012
VS: VS 2010

Reply
Akbarpasha responded on 15 Oct 2018 7:50 PM

Hi Nikolao/Raheel,

We have installed AX 2012 R3 in one machine and SQL server 2016 in another machine, based on SSRS reports requirement we have installed Visual studio 2013 in AX machine , and trying to installed the component "Visual studio tools", but getting the below error :

Is there anyway to continue with these version and fixed the above error, Please advise us.

Regards,

Akbar

Reply
Suggested Answer

Have you installed the SQL Business Intelligence Development Studio like the error message asks you to? You might need to install it on the same machine where you have Visual Studio.

Reply
Akbarpasha responded on 16 Oct 2018 1:39 AM

HI Nikolas,

yes we have installed SQL Business Intelligence Development Studio for Visual studio 2013.

We have installed first Visual Studio 2013 as we have SQL server 2016, but the validation was asking about "Visual studio 2010 SP1" so we have installed Visual studio 2010 and its SP1,

one more thing is that "Application Explorer" is appearing in Visual Studio 2010 not in Visual studio 2013, as per our understanding it should appear in VS2013,

Can we installed SQL Business Intelligence Development Studio for VS2010.

We have installed VS2013, SSDT 2013 tools and VS2010 SP1 in AX server, do we need to install anything in SQL server 2016 machine as well?

please advise us the next steps to be followed.  

Regards,

Akbar

Reply
Suggested Answer

Don't install multiple versions of Visual Studio, install only the one that is compatible with the AX version that you are installing.

Which validation was asking about "Visual Studio 2010 SP1"?

I think it's best that you remove both VS installations and AX VS tools component. Then reinstall only the VS version that you need, and after that install the AX VS tools component.

Reply
Akbarpasha responded on 16 Oct 2018 2:12 AM

Yes Nikolas,

we have done the same thing, we have installed only VS2013 and SSDT tools for VS2013 only, still while validating the "Visual studio tools" from AX setup it was asking"updates for Microsoft Visual Studio 2012" , please refer the screen shot.

Please advise us.

Reply
Suggested Answer

Which exact AX version you are using? VS 2013 is used from CU8 onwards.

So I think you should have CU8 or higher update in your "Updates" folder of AX installer. Otherwise it's trying to install an older version, which is only compatible with VS2010.

Please look into AX 2012 system requirements document for more information. There it also says "Different versions of the AX 2012 Visual Studio Development Tools cannot be installed side by side."

Reply
Verified Answer

You need the SQL Server before you can install AX, and you need VS before you can install AX VS tools, so your plan sounds correct.

Please also understand that AX has multiple components which might need to be installed in specific sequence.

Reply
Raheel Khan responded on 11 Oct 2018 11:53 AM
My Badges
Verified Answer

1- SQL Server

2- AOS

3- Visual studio

4-AX VS tools

5-Client

Please mark answers as suggested if these are helpful for you

Reply
Raheel Khan responded on 12 Oct 2018 12:12 AM
My Badges
Verified Answer

What about this?

Reference: http://msdynamicsaxtips.blogspot.com/2015/02/unable-to-preview-report-install.html

After that restart SQL and AOS Services, If issue remain same, then I will recommend you to install same version of all of these applications like:

 AX: AX 2012 R3
OS: Windows Server 2012
SQL: SQL 2012
VS: VS 2010

Reply
Suggested Answer

You will find all the information you need in Dynamics AX 2012 System Requirements document: www.microsoft.com/.../details.aspx

Here is Dynamics AX 2012 installation guide: www.microsoft.com/.../details.aspx

If you don't want to install everything yourself, you can also deploy fully configured dev environments from Lifecycle Services to your Azure subscription. Or download a demo VHD, which contains all dev tools as well.

Please see more info here: docs.microsoft.com/.../deploy-2012-r3-azure-lcs

Reply
Raheel Khan responded on 11 Oct 2018 2:40 AM
My Badges
Suggested Answer

Salam!

Dear Akbar,

Hope you are fine!

You must read Microsoft Dynamics AX 2012 System Requirements for successful AX implementation, if you don't want to read it out just go for this link and take a basic prerequisites mentioned below link.

http://dynamics-ax.blogspot.com/2012/11/microsoft-dynamics-ax-2012-system.html

Reply
Raheel Khan responded on 11 Oct 2018 11:53 PM
My Badges
Suggested Answer

Dear Akbar,

Have you installed Developer Tool (VS Tools) on your AOS where you want to edit report?

Reply
Suggested Answer

Have you installed the SQL Business Intelligence Development Studio like the error message asks you to? You might need to install it on the same machine where you have Visual Studio.

Reply
Suggested Answer

Don't install multiple versions of Visual Studio, install only the one that is compatible with the AX version that you are installing.

Which validation was asking about "Visual Studio 2010 SP1"?

I think it's best that you remove both VS installations and AX VS tools component. Then reinstall only the VS version that you need, and after that install the AX VS tools component.

Reply
Suggested Answer

Which exact AX version you are using? VS 2013 is used from CU8 onwards.

So I think you should have CU8 or higher update in your "Updates" folder of AX installer. Otherwise it's trying to install an older version, which is only compatible with VS2010.

Please look into AX 2012 system requirements document for more information. There it also says "Different versions of the AX 2012 Visual Studio Development Tools cannot be installed side by side."

Reply
Suggested Answer

Like I said, please remove both VS installations and all related components. Then try to install only VS2013 related components, but make sure you have the CU9 package in your AX install media's Updates folder.

Reply
Suggested Answer

Yes you can copy it.

Without the update you are installing AX2012 R3 RTM version, which does not support VS2013.

Reply

SBX - Two Col Forum

SBX - Migrated JS