SBX - Search With Button

SBX - Forum Post Title

Workflow not working properly

Microsoft Dynamics AX Forum

Rajdip Das asked a question on 23 Feb 2010 2:45 AM
My Badges

Question Status

Unanswered

Hi All,

We made all the necessary pre-requisites (as per our knowledge) of workflow & tried our best to execute but we were failed to execute. to give you a better understanding where we do stand i am giving you one phase wise scenario

1) Configured workflow template and tasks and has activated the same..

2) Entered the transaction and has "Submit" the same.

3) Going through Action->View History" i am "refreshing" it, but the work items are not coming neither Approve & Reject is coming . Workflow allowable Access bar is coming but button shows only "View History" item. Approve & Reject is not coming under the button.

We are assuming that we are missing a simple step of configure.

Please help  us with your valuable opinion..

Reply
SUDHAKAR POTTURI responded on 23 Feb 2010 5:07 AM
My Badges

Hi

In the adminsitration did u ron workflow configuration wizard. and validate workflow portal

then go to basic setup workflow settings and process starter

check number sequences are assigned and some batch is assigned (not madatory)

 Then run processor once.

Regards

Reply
Harry responded on 23 Feb 2010 7:17 AM
My Badges
Hi Rajdip,

Try the following:

Visit http://msdn.microsoft.com/en-us/library/cc616520.aspx


The workflow stops after the Submit button is clicked

  • If you use the WorkflowWorkCalendarDueDate provider, work items must have valid Working Times available in the system calendar to complete the work item. To set working times, on the Common forms pane in the Basic module, click Calendar.

  • A security key is required on all display and menu items for workflow task and approval elements.

  • Are workflow system accounts set up for workflow? On the Setup pane in the Administration module, expand the Security node, and then click System accounts. On the System service accounts form, set an Alias and Network domain for the Workflow System Account and the Workflow Execution Account.

  • Verify that the batch job is running or if the workflow batch job is in the batch job queue.

  • Verify that the IIS is running.

  • Check the Windows Event log on both the AOS and the computer hosting the IIS.


Hope it helps. Let me know.

Aman

amannain1@gmail.com

Reply
Trieu nguyen responded on 23 Feb 2010 7:57 PM
My Badges

Hi Rajdip,

Do you already config batch group and batch server ? You must config batch group and batch server for workflow

 Hope for your help

 Best regard

Trieu nguyen

Reply
Rajdip Das responded on 23 Feb 2010 10:14 PM
My Badges
Hi Aman, Thanks for your reply. I didn't configure Calender for Working Times. I let you know after little while after completing some steps including ur steps. Thanks.. keep in touch...
Reply
Rajdip Das responded on 23 Feb 2010 10:22 PM
My Badges

Hi Trieu,

Thanks for your reply. I didn't configure batch file but now I made and also maintain the words of Aman but till the problem is remain same. I made: Batch Job, Batch Task but nothing new is happening. I think I made a simple mistake during the setup or configuration. Can some provide me a document for full Workflow cofiguration step by step in any module. It will be very helpful for me. Thanks. My mail id: rajdipwrites@hotmail.com

Reply
Harry responded on 23 Feb 2010 11:14 PM
My Badges

Hi Rajdip,

For a step by step workflow setup visit: http://workflowax.wordpress.com/2010/01/12/workflow-walkthrough-infrastructure/

Check one thing, 

Administration > Setup > Server configuration,

checkbox "Is batch server" should be checked for the instance. That was the step i was missing in my workflow.

 

Hope it helps.

Aman

Reply
Rajdip Das responded on 23 Feb 2010 11:34 PM
My Badges

Thanks Aman... your link is really usefull. I will let you know the status. Yes Aman Check Box is checked.

Reply
Rajdip Das responded on 4 Mar 2010 9:48 PM
My Badges

Hi Aman,

Thank you very much for your support. Your given link is very usefull. Finally we've managed to get started workflow. Can you provide me a information? Is workflow run in Oracle 10g databese sucessfully? We have some doubts on this. Please let me know at your convenient. Thanks again....

Reply
Arjun Reddy responded on 10 Mar 2010 3:26 PM
My Badges

 I'm trying to Install Workflow on DAX....

I have couple of errors, it says no .NET business connector session could be found.

Also I have the same Proxy account, but when I add it to System services Account it says it does not exist for alias and Network name I provide.

Finally Workflow Status is pending even after I submit...................

Please let me know what needs to be done here..............

Reply
Harry responded on 10 Mar 2010 10:07 PM
My Badges

Hi Arjun,

It will be better if you follow the following steps for setting up the workflow infrastructure.

http://workflowax.wordpress.com/2010/01/12/workflow-walkthrough-infrastructure/

And this one for troubleshooting.

http://msdn.microsoft.com/en-us/library/cc616520.aspx

Hope it helps. Let us know.

Aman

 

Reply
Rajdip Das responded on 10 Mar 2010 11:41 PM
My Badges

Hi Aman,

Thanks for your support. We have managed workflow successfully in SQL Server 2008 with DAX 2009. But a problem is arised that we can't configure workflow in Oracle database. We have made all the procedures like SQL Server 2008 but "Tracking Details" doesn't generate the tree. Whereas in SQL Server it is running very smoothly. Some questions are arised in my mind is workflow run in Oracle environment? Does it require some patches for both Oracle or Axapta? We have continuously tried for it but till today no solution came? Please suggest.

Reply
Mohamed Amine HAMDAOUI responded on 11 Mar 2010 1:50 AM
My Badges

Hi,

 I don't think that workflow component depend on the database used. We have successfully run it both in SQLServer and Oracle with out any patch. I agree with you that the use of Oracle database cause a lot of problems.

Just folow these steps correctely and hope it will work : http://technet.microsoft.com/en-us/library/dd309707.aspx

Best Regards

--------------------
Mohamed Amine HAMDAOUI
Dynamics Ax Technical Consultant
Vi-One North Africa - VISEO Group
Mail : mhamdaoui@viseo.net
Reply
Arjun Reddy responded on 11 Mar 2010 1:11 PM
My Badges

 Hi Aman,

 

I have installed exactly according to the link you have provided. 

On the Installation page we give the AOS service user right? other thing do we need add that user to Dynamics AX. if so what permissions....

I have created .NET Business Connector Account, but when I go to System Service accts in Administration it says alias and network domain are not valid....

When pointing to AOS, do we need to give the Domain\computer name $ or regular AOS service acct we created earlier 

seattle\AOSuser. 

I appreciate all your help.

 

Thanks,

Arjun

Reply
Arjun Reddy responded on 11 Mar 2010 4:52 PM
My Badges

 Aman,

Ok When I run  my Workflow configuration wizard, the workflow URL is valid....but still the workflow in pending status..

 Not sure where it is stuck, only reason I see is the Alias and Network domain for proxyacct don't get validated. But I check everything and it seems fine.


Thanks,

Arjun

Reply
Arjun Reddy responded on 11 Mar 2010 5:07 PM
My Badges

 Can I please know what all I need to do while setting up .NET Business Connector Proxy Account

 

Thanks,

Arjun

Reply

SBX - Two Col Forum

SBX - Migrated JS