The parameter "do not allow gaps in historical data" does not work.

I understand that it should add zeros to historical demand when there is no value in a past period… but it does not do it.

Even more, it creates very strange predictions when it is marked for some articles.

I have also tried to set up "missing value substitution" parameter to 0. But it does not fill with 0 historical periods.