Today while working with unified interface I encountered an issue where “editable gird” was not getting displayed on the form when using a browser. Even though I had chosen editable grid control for that particular sub-grid.

After lot of tries I identified that if “Read-only for mobile” property on the Entity is checked the “editable grid” does not work in unified interface.

ReadOnly-For-Mobile

To make it work you will have to uncheck “Read-only for mobile” option on Entity property.

Given the fact that unified interface works across all clients, it was not a surprise that some of the toggles for ‘mobile’ affects unified interface apps, but definitely needs some terminology updates.