Yesterday i was deploying to another environment a solution and the import was failing.


The error in the log file was while importing a Process:

Failure

0x80040359

The Microsoft Dynamics CRM record could not be created.


So, i went back to the solution from the other environment and i have checked what could be wrong, apparently nothing was wrong, it was a standard CRM Process with a call to a custom workflow activity, an if condition and 2 Stop Workflows statements (Success & Cancelled). I double checked, yes, i was exporting in the same solution file the Workflow dll, and it has been working since ever.


Next, i removed the custom workflow call, tried again and nothing. What usually i do when i need some extra information, Diagtool, so I enabled the logging, checked the log file on the server and .....

and nothing. No more extra information to help me to see what was the problem.


I went back to the Process and instead of having the check box checked for "Record is deleted" on a Sync Process on a custom entity, i unchecked and checked the "Record is created".


Tried to import again, and yes, it worked.

Did it happen to any of you? Comments are welcome.


Hope it helps.