A few days ago somebody raised a question in the community forums:


Currently, Microsoft Dynamics 365 requires the .NET Framework version 4.6.2 for plug-in assemblies. Rebuild the assembly with the .NET Framework version 4.6.2 and try again.”

Well, it’s hard to know what’s happening in various environments, so I made a note for myself but did not pay too much attention. That is until a few days later somebody else (yes, Rob K), mentioned that he could not import my TCS Tools solution into V9.

That sort of rang a bell, but I still did not make the connection right away.

To my surprise, I got exactly the same error when I tried importing TCS Tools into a new V9 trial a day or two later.

If you look at the thread there, you’ll find a response from Vladimir Karukes – basically, we need to specify 4.5.2 target for the plugin assembly to avoid the error. Turned out he was spot on.

In case with TCS Tools, here is what happened:

  • I’ve always been building it using the on-prem version, and it works fine with 4.6
  • So the target FW version of my assemblies used to be 4.6(?)
  • At which point did it stop working in V9, I am not 100% sure, but, looking at that thread in the community forums, it seems there was some recent change

So yes, rebuilding for 4.5.2 did solve the problem.

But, before I got to 4.5.2, I actually tried 4.7.2.. Guess what error message came up then? It was exactly the same error, but it was saying that my assembly was supposed to target 4.7.2 this time around.

In other words, the error message seems to be misleading – Dynamics seems to be looking at the actual target FW version of the assembly and just echoing that version number where it should be asking for 4.5.2(since it seems to be the highest supported version in the online environment).