SBX - Search With Button

SBX - Forum Post Title

Business rules not working with change UI language

Microsoft Dynamics CRM Forum

Alexandr Jermolajev asked a question on 9 Nov 2018 8:03 AM
My Badges

Question Status

Verified

Hi,

i have couple of business rules (BR) on Lead entity and all works well with any user role for anyone in base language = English. But with change UI language to any other BR will stop working (any of them). I already tried to change BR and made them simplier with just 1 step (like show/hide 1 field with/without any condition) but they still not working.

It's happening just on Lead entity, at other entities BR works well, but true is i don't have too much BR's on other entities like on Lead. We have CRM 2016 - 8.0.1.79. 

Is it possible to exceed maximum number of BR's? 

Thanks for any advice.

Reply

Hi,

Do you have any check with any value with English label? Might be this is translated and not satifying the condition .

Reply
Alexandr Jermolajev responded on 9 Nov 2018 8:45 AM
My Badges

Hi,

thanks for fast answer. I checked already all labels and rename them when it was same, but anyway this can be problem for some BR but not all i think..? Our base language is English (just for me admin) and users working just with Czech language so i'm making translations just for Czech. I tried any other language at our CRM and BR's on Lead actually working just with English.

Reply
Suggested Answer

Hi, What is the scope  of business rules ? Can you please check whether they set to all forms ?

Reply
Alexandr Jermolajev responded on 9 Nov 2018 9:05 AM
My Badges

It's combination of different scopes - i have main 2 forms for each of them i have 3-5 BR's (every of these BR's are scope=form). Next for example 5 BR's are scope=All forms and next 5 scope=Entity. At all i have on Lead 17 BR's cause some BR's must be split for max. 10 conditions. Any of these BR's actually not working.

Reply
Verified Answer

Try to deactivate and activate and check one business rules.

In addition I would suggest create one simple Business rules like

If fieds does contains data

Hide some other fields.

See if it's working or not.

Reply
Alexandr Jermolajev responded on 9 Nov 2018 9:26 AM
My Badges

The problem was one of old BR's, which was activated but does not contain any data (just name of BR) so when i tried to open detail of this BRit shows error message. I don't know if it was deleted or how this happened cause i checked all BR's when problem happends first time but deactivating and delete of this BR now solve my problem.

I will test it more with another user role but now it looks OK.

Thanks a lot for cooperate!

Reply
Verified Answer

Try to deactivate and activate and check one business rules.

In addition I would suggest create one simple Business rules like

If fieds does contains data

Hide some other fields.

See if it's working or not.

Reply
Suggested Answer

Hi, What is the scope  of business rules ? Can you please check whether they set to all forms ?

Reply

SBX - Two Col Forum

SBX - Migrated JS