Can not open documents from document location

This question is answered

We don't seem to be able to select documents or the folders (which are in sharepoint) on the CRM 2011 form. It almost looks like a read only screen. Any ideas?

 

Verified Answer
  • OK  obviously a security update somewhere as now IE is displaying the same as Firefox. Sharepoint shown in an IFrame. However must say I preferred the original form and link in IE.

All Replies
  • The Microsoft Dynamics CRM 2011 List component for SharePoint makes your Microsoft Dynamics CRM documents that are stored on SharePoint available to you in a format that has the look and feel of Microsoft Dynamics CRM. This component also enables Microsoft Dynamics CRM to automatically create folders that will be used to store documents related to Microsoft Dynamics CRM records on SharePoint.

    www.microsoft.com/.../details.aspx

    M.Adeel

  • Thanks for the post, but as usual it not quite that simple. We have now run some tests. It appears to be a IE authentication issue. In IE8 IE9 and IE10 the same problems. Log in with Firefox and whislt you have to log into the sharepoiunt site, all the links are there.

    So what has someone tinkered with I wonder? Could it be IE?

  • Yes it could be a problem with IE. To ensure that whether its a problem with IE you can do the following:

    On the Internet Explorer> Tools> Internet Options> Advanced tab> click Restore defaults button and Click "OK" . See if it works.

    M.Adeel

  • Also de-select "Automatically Detect Settings" under LAN setting part in Internet Explorer if applicable to you.

    M.Adeel

  • Actually some websites contain scripts that are not compatible with IE 8 or later even in compatibility mode and therefore the problem may persist.

    M.Adeel

  • In some instances reinstall of IE may also fix the problem.

    M.Adeel

  • Hi Michael,

    • put your CRM url and your SharePoint url in the locale intranet zone of your IE
    • delete temporary files from %localappdata%\Microsoft\Windows\Temporary Internet Files
    • log in to both services
    • try again the integration in IE

    You could also have a look at your securityroles, check the privilege for "Documentlocation" and "SharePoint Website".

    Regards
    Benjamin 

  • Hi Benjamin

    thanks for the info. Unfortunately no success. We have recently updated to Roll up 12 +13 as well. The annoying thing is it works ok in firefox. Interestingly the firefox interface opens up the sharepoint window as an iframe. Strange but true Microsoft has created an issue that did not exist.

  • I know three reasons that forces CRM to show the IFrame

    • CRM List Component is not installed correctly or there is something wrong with the entered url in CRM
    • Push too fast after page load the "Document" button, so that the required script is not yet loaded
    • There are other scripts do not work properly

  • OK  obviously a security update somewhere as now IE is displaying the same as Firefox. Sharepoint shown in an IFrame. However must say I preferred the original form and link in IE.