Question Status

Verified
Matt Henry asked a question on 4 Feb 2015 1:54 PM

Hello,

I am experiencing an issue with on-premise CRM 2013 where after creating a new opportunity, several (5) duplicate auto posts are created which indicate the opportunity was created. I have several plugins which listen for opportunity Update events, but no creation, and setting breakpoints while using Visual Studio and a remote debugger did not cause any breaks during the save process. In addition, I see one record in the audit log, and I have also stepped through any javascript and there aren't any additional saves occurring from the browser.

I am wondering what event exactly would cause these auto posts to be created, and where should I look for the source of this?

 

Reply
Verified Answer
Prashant Shukla responded on 4 Feb 2015 2:33 PM

Hi Matt

I guess you have imported many solutions/customization in your CRM, However, here is a work around:

Go to settings>>Customizations>>Customize the system>>SDK Messages

You will see that there are multiple auto-posts plugins enabled for same event on same entity, disable them & let only one enabled:

CRM-tude

Prashant Shukla

Make sure to Vote as Helpful and  Mark As Answer ,if you get answer of your question.

Reply
Suggested Answer
Prashant Shukla responded on 4 Feb 2015 4:18 PM

Do not forget to click on Publish button after that

CRM-tude

Prashant Shukla

Make sure to Vote as Helpful and  Mark As Answer ,if you get answer of your question.

Reply
Matt Henry responded on 5 Mar 2015 11:54 AM

Prashant,

Thank you for this response earlier... however, I am wondering why only the ActivityFeeds plugin SDK messages are duplicated on a default solution import. For example, we have a third-party plugin library as well as our own, yet these associated SDK messages are not duplicated. What do you recommend to handle this situation?

Thank you!

Reply
Verified Answer
Prashant Shukla responded on 4 Feb 2015 2:33 PM

Hi Matt

I guess you have imported many solutions/customization in your CRM, However, here is a work around:

Go to settings>>Customizations>>Customize the system>>SDK Messages

You will see that there are multiple auto-posts plugins enabled for same event on same entity, disable them & let only one enabled:

CRM-tude

Prashant Shukla

Make sure to Vote as Helpful and  Mark As Answer ,if you get answer of your question.

Reply
Suggested Answer
Prashant Shukla responded on 4 Feb 2015 4:18 PM

Do not forget to click on Publish button after that

CRM-tude

Prashant Shukla

Make sure to Vote as Helpful and  Mark As Answer ,if you get answer of your question.

Reply