Question Status

Verified
Ben Tan asked a question on 3 Aug 2015 9:57 AM

Hi All

We recently received the May 2015 Update for CRM Online. Since then, the 'Revise' button has not been working in Quotes. All other buttons (New, Delete, Create Order etc.) are working fine. Nothing has changed since before the update was applied and the roles for individuals are still the same.

Has anyone else been affected by this? Is there a fix for this, save from me deleting the quote and starting again??

Any help gratefully received.

Thank you in advance!

Reply
Wayne Walton responded on 3 Aug 2015 10:06 AM

How does it not work?  Do you have custom logic on quotes? Since this seems to be update-related, have you reached out to Microsoft Support?

Reply
Ben Tan responded on 3 Aug 2015 10:29 AM

Hi

Many thanks for your quick response.

When I say, 'is does not work', I mean that nothing happens when I click on it. I tried this on various machines in the office under different accounts and got the same result. I am currently set as a CRM administrator so permissions should not be an issue, right?

I have attempted to contact Microsoft Support through many different channels (phone, email, live chat) but keep getting passed from department to department, person to person. This is my last resort.

I do not have any custom logic on Quotes.

As you say, this seems to be update related and I am trying to find out if this is an inherent problem with the update, in which case, is there a workaround in the meantime before a fix is applied?

Thanks again.

Reply
Suggested Answer
Wayne Walton responded on 3 Aug 2015 10:42 AM

I'd follow up on your support request, and make sure this is impacting a life system and is critical.  I'd also follow up with your Microsoft Partner (assuming you have one) and see if they can escalate through their channels.  The sales department sometimes can light a fire internally on support.

Reply
Suggested Answer
Victor Crespo responded on 3 Aug 2015 10:27 PM

Hello Ben

This is an issue that has been reported before to CRM Online Support.

It seems there is an issue with the new render engine used in some forms, the workaround at this moment is activate the "Legacy render" in Settings.

This setting can be found under Settings -> Administration -> System Settings -> General. Select “Yes” under “Use legacy form rendering” to enable this mode for all users.

Thank you for using Microsoft Dynamics Communities

Victor Crespo

Support Engineer | Dynamics CRM Online Support

Reply
Ben Tan responded on 4 Aug 2015 3:28 AM

Hi Victor

Many thanks for your response.

I was pleased to learn that this has been an issue before and that this is a workaround. Unfortunately, having followed your instructions, I am still unable to get the 'Revise' button to function. Should it take immediate effect?

Reply
Damon (nomad) responded on 4 Aug 2015 3:06 PM

Hi Ben:

Yes it takes immediate effect.

Have you tried a different browser. What browser and version are you using.

Reply
Victor Crespo responded on 4 Aug 2015 6:28 PM

Hello Ben

Yes, this should take action immediately.

I would also recommend you to open a Service Request Ticket to CRM Online Support, so they can advise you if this is a bug or not and, if it is, when is planned to be solved.

You can do this by following the instructions on this link:

blogs.technet.com/.../how-to-create-service-requests-to-contact-office-365-support.aspx

Thank you for using Microsoft Dynamics Communities

Victor Crespo

Support Engineer | Dynamics CRM Online Support

Reply
Ben Tan responded on 5 Aug 2015 5:56 AM

Hi Victor

Unfortunately this has not fixed the issue. We have raised a ticket through Microsoft support so we will wait and see if they can provide any assistance. It's just taking a rather long time and this issue is affecting out business productivity.

In the meantime if you have any other suggestions I would be grateful to hear them...

Reply
Ben Tan responded on 5 Aug 2015 6:02 AM

Hi Damon

I have tried in a number of browsers; IE, Edge, Chrome & Firefox. In all browsers the 'Revise' button' is not functioning :(

Many thanks

Ben

Reply
Verified Answer
Ben Tan responded on 12 Aug 2015 3:37 AM

Hi All

Many thanks for all your responses.

Having followed this up with Microsoft Support, it seems that this has been an issue before. Apparently, there were some fields missing from the entity which are required in order for the 'Revise' function to work.

I was asked to add in the 'Description' & 'Freight Amount (Base)' fields into the form and this seems to have sorted the problem.

Seems a bit silly. If these are required fields then they should be locked on the form.

Anyway, the problem is fixed.

Thank you again for your time.

Reply
Suggested Answer
Patric responded on 30 Sep 2015 12:04 AM

Hello Ben,

Many thanks for logging in your findings. I had the same issue, applied your solution. it works for me. I had to just place the fields on the form and hide it from user view. This issue occurs only after upgrading to 1.0. The other way to get rid of this error is to use legacy form rendering, this will adversely affect the form load performance or defuse the purpose of upgrade 1.0.

Adding these two fields resolved my issue, now able to experience both features.

Thank you

Reply
Suggested Answer
Mohammed Hameed Hussain responded on 29 Aug 2016 6:14 PM

Thanks, Ben.

We were upgrading from 2013 to 2016 and had the same issue. Your answer helped me fix the issue.

Reply
Tulkos responded on 17 Nov 2016 2:27 AM

You are the man, Ben Tan!

Unfortunately, this is still an issue (V 8.1.0.534 / CRM Online).

Reply
SquirrelChaser responded on 12 May 2017 4:34 PM

FYI, this problem hit us with CRM on premises with the 8.2.0.749 release (Dynamics 365). Ben's fix worked great as well. Thanks!

Reply
Verified Answer
Ben Tan responded on 12 Aug 2015 3:37 AM

Hi All

Many thanks for all your responses.

Having followed this up with Microsoft Support, it seems that this has been an issue before. Apparently, there were some fields missing from the entity which are required in order for the 'Revise' function to work.

I was asked to add in the 'Description' & 'Freight Amount (Base)' fields into the form and this seems to have sorted the problem.

Seems a bit silly. If these are required fields then they should be locked on the form.

Anyway, the problem is fixed.

Thank you again for your time.

Reply
Suggested Answer
Wayne Walton responded on 3 Aug 2015 10:42 AM

I'd follow up on your support request, and make sure this is impacting a life system and is critical.  I'd also follow up with your Microsoft Partner (assuming you have one) and see if they can escalate through their channels.  The sales department sometimes can light a fire internally on support.

Reply
Suggested Answer
Victor Crespo responded on 3 Aug 2015 10:27 PM

Hello Ben

This is an issue that has been reported before to CRM Online Support.

It seems there is an issue with the new render engine used in some forms, the workaround at this moment is activate the "Legacy render" in Settings.

This setting can be found under Settings -> Administration -> System Settings -> General. Select “Yes” under “Use legacy form rendering” to enable this mode for all users.

Thank you for using Microsoft Dynamics Communities

Victor Crespo

Support Engineer | Dynamics CRM Online Support

Reply
Suggested Answer
Patric responded on 30 Sep 2015 12:04 AM

Hello Ben,

Many thanks for logging in your findings. I had the same issue, applied your solution. it works for me. I had to just place the fields on the form and hide it from user view. This issue occurs only after upgrading to 1.0. The other way to get rid of this error is to use legacy form rendering, this will adversely affect the form load performance or defuse the purpose of upgrade 1.0.

Adding these two fields resolved my issue, now able to experience both features.

Thank you

Reply
Suggested Answer
Mohammed Hameed Hussain responded on 29 Aug 2016 6:14 PM

Thanks, Ben.

We were upgrading from 2013 to 2016 and had the same issue. Your answer helped me fix the issue.

Reply