Hello Community Team,

We are trying to debug the custom workflow which we have created on CRM on-premise environment  and for the same purpose we are following the debugging steps for on-premise.

CRM server details

Version : 8.2 on-premise

Please find the screesnhot for the below steps:

However, while executing the second steps we are unable to update the deployment to on-disk.

Note:-

Application server and the database server for the CRM on-premise are different.

Please find below the error log which we are getting while performing the step.

--------------------------Error log Start---------------------------------

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=9.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Unable to load plug-in assembly.

Detail: <OrganizationServiceFault xmlns="">schemas.microsoft.com/.../Contracts" xmlns:i="">www.w3.org/.../XMLSchema-instance">

  <ActivityId>530f4124-d32e-478f-9ff7-7a7ffd2874bb</ActivityId>

  <ErrorCode>-2147204719</ErrorCode>

  <ErrorDetails xmlns:a="">schemas.datacontract.org/.../System.Collections.Generic" />

  <HelpLink i:nil="true" />

  <Message>Unable to load plug-in assembly.</Message>

  <Timestamp>2021-08-11T08:41:06.7101646Z</Timestamp>

  <ExceptionRetriable>false</ExceptionRetriable>

  <ExceptionSource i:nil="true" />

  <InnerFault>

    <ActivityId>530f4124-d32e-478f-9ff7-7a7ffd2874bb</ActivityId>

    <ErrorCode>-2147204719</ErrorCode>

    <ErrorDetails xmlns:a="">schemas.datacontract.org/.../System.Collections.Generic" />

    <HelpLink i:nil="true" />

    <Message>Unable to load plug-in assembly.</Message>

    <Timestamp>2021-08-11T08:41:06.7101646Z</Timestamp>

    <ExceptionRetriable>false</ExceptionRetriable>

    <ExceptionSource i:nil="true" />

    <InnerFault i:nil="true" />

    <OriginalException i:nil="true" />

    <TraceText i:nil="true" />

  </InnerFault>

  <OriginalException i:nil="true" />

  <TraceText i:nil="true" />

</OrganizationServiceFault>

Server stack trace:

   at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)

   at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)

   at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)

   at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:

   at Microsoft.Crm.Tools.Libraries.RegistrationHelper.RegisterAssembly(CrmOrganization org, String pathToAssembly, CrmPluginAssembly assembly)

   at Microsoft.Crm.Tools.AssemblyRegistration.PluginRegistrationViewModel.btnregisterClick()

----------------------------Error Log End-----------------------------------------

Request to please help on this critical issue as soon as posible.