Skip to main content

Notifications

Announcements

No record found.

Dynamics 365 Community / Forums / Commerce forum / How to support differe...
Commerce forum
Suggested answer

How to support different scaleunit releases

Posted on by 41
Hi!
 
1. With every release of Dynamics Commerce ex: as below.
 
 
Do we need to build our solution for each of these Releases separately
OR
Higher release will support solution build with lower releases
 
Recently I got error while compiling the solution as below and works for 9.46.* version but not for 9.47.*

Error    NU1107    Version conflict detected for Microsoft.Dynamics.Commerce.Diagnostics. Install/reference Microsoft.Dynamics.Commerce.Diagnostics 10.13.23290.1 directly to project ScaleUnit to resolve this issue. 
ScaleUnit 
-> CommerceRuntime 
-> Microsoft.Dynamics.Commerce.Sdk.Runtime 9.47.24095.2 
-> Microsoft.Dynamics.Commerce.Runtime.Services.Messages 9.47.24064.5 
-> Microsoft.Dynamics.Commerce.Diagnostics (>= 10.13.23290.1 && < 10.14.0) 
ScaleUnit -> 
SampleApplication.ScaleUnit.Packaging 1.1.0.0 
-> SampleApplication.StoreCommerce.Pos 1.1.0.0 
-> Microsoft.Dynamics.Commerce.HardwareStation.Core 9.46.23357.1 
-> Microsoft.Dynamics.Commerce.Diagnostics (>= 10.12.23177.1 && < 10.13.0).    
 
Thanks!
Navneet Hegde
  • Suggested answer
    CU14071128-0 Profile Picture
    CU14071128-0 on at
    How to support different scaleunit releases
    To manage various details on different scales, you can use the following approaches:
    1. AutoCAD LT:
      • Draw everything at a 1:1 scale in model space.
      • Create detailed blocks for different scales (e.g., 1:100, 1:50, 1:20).
      • Use layout tabs with different scales and set line thickness and transparency accordingly.
      • Freeze layers individually in each viewport to manage visibility.
    2. Power BI:
      • Use the small multiples feature to display multiple measures.
      • Utilize the SWITCH() function and a table of measures to format the x/y axis scale individually.
      • Refer to the Power BI documentation for workarounds and updates on this feature.
    3. TIBCO Sfire Analyst:
      • Use dual scales or multiple scales on an axis to visualize measures with different magnitudes or units.
      • Assign measures to each scale based on color axis settings.
      • Customize scales for different visualization types, such as bar charts, line charts, and scatter plots.
    4. MATLAB:
      • Create multi-lined x-axis ticks to include multiple axis units.
      • Use the upper axis as the main axis for plotting data.
    These approaches allow you to effectively manage details on different scales in various software applications.
     
     
     
    Hi you may also interested in getting a big big discount!
    
    Download the app Temu on google play and use the code:
    Temu coupon code (act200019) $100 off for new users
    
    Temu Coupon Codes: Use  [ACT200019] & Enjoy Instant Savings






     


     
  • Navneet Hegde Profile Picture
    Navneet Hegde 4 on at
    How to support different scaleunit releases
    For some reason I am locked from my work account. so replying with another account


     
    That was my understanding, but client is merging our extension which is compiled on 9.46 with their ScaleUnit which is on  9.47 release.
     
    and they want us to provide extension build on 9.47 as well else they get the error as below.
    which seems like upper limit of Diagnostics dll for 9.46 is 10.13.0 while 9.47 start's from 10.13.232* and again ends on 10.14 which which seems like tightly  coupled to specific release version  
     
    ScaleUnit 
    -> CommerceRuntime 
    -> Microsoft.Dynamics.Commerce.Sdk.Runtime 9.47.24095.2 
    -> Microsoft.Dynamics.Commerce.Runtime.Services.Messages 9.47.24064.5 
    -> Microsoft.Dynamics.Commerce.Diagnostics (>= 10.13.23290.1 && < 10.14.0) 
    ScaleUnit -> 
    SampleApplication.ScaleUnit.Packaging 1.1.0.0 
    -> SampleApplication.StoreCommerce.Pos 1.1.0.0 
    -> Microsoft.Dynamics.Commerce.HardwareStation.Core 9.46.23357.1 
    -> Microsoft.Dynamics.Commerce.Diagnostics (>= 10.12.23177.1 && < 10.13.0).    
    ScaleUnit    H:\source\src\ScaleUnit\ScaleUnit.csproj    1 
     
    Thanks!
    Navneet Hegde
  • Suggested answer
    CU26061657-0 Profile Picture
    CU26061657-0 17 on at
    How to support different scaleunit releases
    THow hig8gygbitt
     
  • Suggested answer
    Shafeeque Mohammed Profile Picture
    Shafeeque Mohammed 6,145 Super User on at
    How to support different scaleunit releases
    You don't need to build solution for every release. Only requirement is that packages should be compiled in same version or earlier version that is on the CSU. We usually make use of the 3 update skip if there are no major bugs or features in the new update. 
     
  • S Gopi Krishna Profile Picture
    S Gopi Krishna 268 on at
    How to support different scaleunit releases
    Hey Navneeth,
     
    Hope this helps Dynamics 365 Commerce component versioning requirements - Commerce | Dynamics 365 | Microsoft Learn. But we usually make sure that our custom extensions are build with the new version that we are planning to update the CSU with.
     
    Will wait to hear what others have to share on this.

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,986 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,588 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans