This issue was specifically brought up during testing in our Upgrade environment but is also seen in our standard Test environment. When we try to use the 'Open lines in excel' functionality of the General Journals form, we receive an error that is thrown from trying to connect to blob storage.
This issue occurs in our non-Production environments only.
We were told to upgrade to PU25 to resolve the issue. We have since upgraded to AU 10.0.1 PU25 and still see the issue. We see this issue in our old 7.1 Test environment as well as our upgrade environment (on both 8.1 and after updating to 10.0.1)
This issue is related to a bad link between the environment and it's blob storage location, I believe from being ported through from Production incorrectly. We have tried re-dropping the DB but it has not solved the issue. We need someone to figure out how the environment is linked to its blob storage - The last Microsoft rep we had on this issue tried recreating the issue in a different environment and was not able to. I need someone experienced with knowledge of how the blob storage functionality works to look at this.
Error message:
Record for Id - {AB29263F-58E7-4379-B1EF-8D28904FB5F0} not found.
Repro steps:
1) Navigate to General Ledger -> Journal entries -> General journals
2) On an open journal, try to use the 'Open lines in excel' functionality
3) Receive error


I appreciate your inputs