web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Microsoft Dynamics GP (Archived)

Microsoft Management reporter 2012 Error

(0) ShareShare
ReportReport
Posted on by

I am getting an error "Database configuration: The password could not be validated against the password policy." while installing Microsoft Management Reporter on the server. Our Management Reporter Server and SQL database servers are separate. Both are able to ping each other.

What could be the reason for that error? How to rectify it?

Somebody Please Help..

 

*This post is locked for comments

  • Community Member Profile Picture
    on at

    some body please help...

  • Ian McQuade Profile Picture
    125 on at

    Hey, ironically I am getting the same issue at the same exact time!  Were you able to determine a solution?  I was able to deploy this in a test environment with a different SQL server with no problems, but am having trouble with my production environment which is setup nearly identically.

  • Suggested answer
    Ryan Sandness Profile Picture
    Microsoft Employee on at

    Is everything on the same domain and have you had any DNS issues? We had someone run into this from them making updates manually in their HOST file that caused some traffic to not hit AD to gather the correct password policy.

    Can you provide some detail of  how your environment / servers are configured?

  • Ian McQuade Profile Picture
    125 on at

    Hi Ryan;

    All is in one domain

    MR is on a seperate server from SQL

    Host file is empty of any manual changes - in fact it is the default

    I can connect via the utility to my dev SQL, no error, not to production

    This is driving me up the wall - I have tried making everyone sysadmin and all sorts

    Thoughts?

    Cheers

    Ian

  • Suggested answer
    Ian McQuade Profile Picture
    125 on at

    I fixed it

    Either a) Shut off the firewall on the SQL Server

    or

    b) Look in the firewall log and open the ports showing dropped packets

    Good Luck and thanks for the fun; nice that the error message  is totally useless and wrong!!!!!!!

    Ian

  • Suggested answer
    Ian McQuade Profile Picture
    125 on at

    Did you get fixed by turning off or opening the ports on the firewall - looking to see if my fix was the same as yours

  • Community Member Profile Picture
    on at

    I just turn off the firewall..But it doesn't help me... Still not able to install MR2012 . But previous version is working fine in the same server.  ..

  • Beat Bucher  GP Geek  GPUG All Star Profile Picture
    28,069 Moderator on at

    Hi Belraj,

    Which version of MR 2012 are you running ? V 2.0 was using a port number for the web server, and this might conflict with the new V2.1 that you're trying to install... I solved the connection issue by removing completely the old version and re-installed from the scratch the 2.1. It detected the old database version and did the upgrade w/o any problems. Upgrading directly the old version did not work for me.

  • Srinivasan Sundaram Profile Picture
    765 on at

    Any Solution till date?  I am doing a fresh install of MR 2012 and running into the same problem.

    What a piece of crap this software - Great Plains is Great PAINS.

  • Ryan Sandness Profile Picture
    Microsoft Employee on at

    Hi,

    There was a KB on this topic. You likely have DNS issues or a firewall turned on for your SQL Server.

    mbs2.microsoft.com/.../KBDisplay.aspx

    CAUSE

    This error is typically caused by a connection problem to the SQL server that will host the Management Reporter database.

    RESOLUTION

    Possible causes of the connection problem:

    General DNS/network issues

    You should be able to successfully "ping" the SQL server from the computer that you are installing the Management Reporter services on.

    Firewall or other network software/hardware blocking the connection

    The range of dynamic ports on the SQL server may be blocked by a software or hardware firewall.

    To view the range of dynamic ports on Windows Server 2008 and later, you can run the following on the SQL server from a command prompt:

    netsh int ipv4 show dynamicport tcp

    MORE INFORMATION

    The password validate function that is used during the Management Report installation tries to connect to the RPC Endpoint Mapper service on the SQL server (port 135). If that is successful, the RPC Endpoint Manager will provide the Management Reporter installer with a port number from the range of dynamics ports on the SQL server. The installer will then try to connect to the SQL server using that port. If either of these connection attempts fail, you will receive the password validation error.  

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > 🔒一 Microsoft Dynamics GP (Archived)

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans