web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Service | Customer Service, Contact Center, Fie...
Answered

Email to a queue and from the Queue to a case but remain tagged as the Queue

(0) ShareShare
ReportReport
Posted on by 5

Hello,

I'm trying to work either with Power automate or Dynamic customer Hub and both side, I can't get it to work and i Know it works...

I created a Queue,

I created a TEAM

I assigned an email to the Queue. ( I approve the email )

I sent an email from my outlook to the queue maibox and the Queue Item are there so I know that works...

I went to advanced setting under Queue

I created a rule called Email Incoming. 

Selected : Create records for email from unknown senders only..

I created a record creation and update rule item with if the emial contains issue or problem to open a case

if so to perform the action which is a case ( i went to set properties and eddited the note section to add dynamicly the Description of the email 

I clicked on save and activated the rule

It told me I had security role issue, I fixed that and now....

it says : You have exceeeded the maximum number of (0) characters in the field. ( HELP )

I'm stuck here... 

problem.png

  • Arshad A Shaikh Profile Picture
    Microsoft Employee on at

    Hello Martin,

    Thanks for reaching out to Dynamics Community.

    As per the details mentioned, you have an Automatic Routing rule set to create a case record on email activity through a specific queue.

    Please click on "Details" in the screenshot, it will give detailed error message. Where the name of field would be present, here the error is due to maximum number of characters on specific field. Check the length of that field and the maximum allowed length.

    Thanks,

    Arshad

    Dynamics Support

  • Martin Pesant Profile Picture
    5 on at

    A validation error occurred.  The length of the 'description' attribute of the 'incident' entity exceeded the maximum allowed length of '2000'.

  • Verified answer
    Arshad A Shaikh Profile Picture
    Microsoft Employee on at

    Hello Martin,

    Thanks for sharing details. As per the information above the limit is set for "Description" field on "Case" (Schema - Incident) is 2000. This limit can be increased manually asper your requirements.This field can contain up to 1,048,576 text characters. You can set the maximum length to be less than this. So when your workflow is triggering its updating description field from email, and due to maximum allowed length its failing. Kindly follow the below steps to manually update the description field :

    Settings > customizations > customize the system > Entities > Case > Fields > Description

    pastedimage1575035958098v1.png

    Once the value is updated beyond 2000 then you should not get this error.

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the July Top 10 Community Leaders

These are the community rock stars!

Leaderboard > Service | Customer Service, Contact Center, Field Service, Guides

#1
Syed Aqib Raza Profile Picture

Syed Aqib Raza 42

#2
11manish Profile Picture

11manish 21 Super User 2026 Season 2

#3
Travis South Profile Picture

Travis South 19

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans