Skip to main content



No record found.

Power Platform integration forum

Issue Deploying Model Driven App - Entity Doesn't Exist

Posted on by
This is my first time posting and i'm trying to Deploy my first Model Driven app to testing.

Unfortunately, I get this error:

PortableBusinessLogic name Non Essential Selector: 'mefs_NonEssExpenditure' entity doesn't contain attribute with Name = 'mefs_nonessentialowner' and NameMapping = 'Platform'. MetadataCacheDetails:

Each form in my app has a Business Rule to show and hide 2 Contact lookups depending on the Option (Client 1, Client 2, JOINT)

I had the issue on a Savings table first so I tried disabling the Business Rule then just deleted it. This solved the issue but now it's gone to the next Business rule. I think something is missing and I just cannot see the issue.

Any ideas where to start looking?

Any help MASSIVELY appreciated

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .


André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 288,459 Super User

Martin Dráb Profile Picture

Martin Dráb 225,783 Super User

nmaenpaa Profile Picture

nmaenpaa 101,148


Product updates

Dynamics 365 release plans