web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Microsoft Dynamics AX (Archived)

Generate Report Loading more than 10 Minutes

(1) ShareShare
ReportReport
Posted on by 2,075

Dear All,

I want to ask about AX Report.

ussualy my report generated in 1 minutes.

right now, its been loading for 10 minutes and not complete yet, 

previously I had tried and its failed because too long .

anyone could advice how to solve this ?

Thank you

*This post is locked for comments

  • benjamin84 Profile Picture
    2,075 on at

    infolog message 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond'

  • Suggested answer
    Chaitanya Golla Profile Picture
    17,225 on at

    Hi,

    Is it standard report or a custom one?Can you give a try by providing suitable filters such that the data to load will be less.Please restart your reporting service, generate the report and check whether is it logging any event in eventviewer.

  • Suggested answer
    Srini Ramidi Profile Picture
    2 on at

    Hello,

    Refer this post:

    community.dynamics.com/.../microsoft-dynamics-ax-2012-ssrs-report-error-a-connection-attempt-failed-because-the-connected-party-did-not-properly-respond-after-a-period-of-time

    Also check the SSRS Log file to see the exact exception details. The SQL Reporting Services log files are found on the reporting services point server, in the folder %programfiles%\Microsoft SQL Server\<SQL Server Instance>\Reporting Services\LogFiles.

    Best,

    Srini

  • Suggested answer
    Community Member Profile Picture
    on at

    Can you explain the problem in more detail please? The information is insufficient for solution.

  • Suggested answer
    Vilmos Kintera Profile Picture
    46,149 on at

    Redesign your report to be pre-processed, that should help with report processing timeouts.

    [View:https://blogs.msdn.microsoft.com/axsupport/2015/09/17/why-does-converting-a-report-to-pre-processing-help-to-resolve-timeout-issues/:750:50]

    Here is a series of articles to boost SSRS performance:

    [View:https://blogs.msdn.microsoft.com/axperf/tag/ssrs/:750:50]

    Also you need to make sure your DB is healthy i.e. by doing regular indexing and statistics updates, you have correct SQL Trace Flags set up, and the DB and TempDB data/log file layout are designed correctly as per SQL Server/AX recommendations.

  • benjamin84 Profile Picture
    2,075 on at

    Hi Devang,

    additional information I got is infolog message 'A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    '

    its true, my report being modified last week.

    do the query too complicated so its drain sql performance during retrieving data ?

    thank you

  • Suggested answer
    Mahmoud Hakim Profile Picture
    17,887 on at

    If connection timed out  , and this report take long time more you expected

    You must check server performance ,if performance is normal ,you can enhance your query

  • benjamin84 Profile Picture
    2,075 on at

    Hi Vilmos,,

    for address : blogs.msdn.microsoft.com/.../why-does-converting-a-report-to-pre-processing-help-to-resolve-timeout-issues

    failed to open 'The page cannot be displayed because an internal server error has occurred.'

    thank you

  • Suggested answer
    Community Member Profile Picture
    on at

    The easiest to diagnose the issue is to catch the SQL statement, see: community.dynamics.com/.../get-from-x-query-to-get-sql-query-using-getsqlstatement-for-trouble-shooting-dynamics-ax-2012

    You can also try to catch the statement with SQL profiler.

    When you got the SQL statement that is executed, copy it to SQL Server Management Studio and execute it with the execution plan enabled. You will see whether there are missing indexes or whether the query is badly written/compiled by AX.

    In case of missing index, create the index on the table through the AOT, synchronize the database and problem should be resolved.(Ofcourse first in an Acceptation environment, indexes can really take a long time to create if they are big in size)

    In case of query that is badly written(Subselects etc.), please resign your report or share the SQL statement so people review it.

  • benjamin84 Profile Picture
    2,075 on at

    Hi Martijn,

    let me check this first.

    Thanks

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Season of Sharing Community Challenge Winners!

Congratulations to our community stars!

Women in Power Builds Momentum

Expanding mentorship, skilling, and AI innovation

Congratulations to the August Top 10 Community Leaders

These are the community rock stars!

Leaderboard > 🔒一 Microsoft Dynamics AX (Archived)

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans