web
You’re offline. This is a read only version of the page.
close
Skip to main content

Announcements

No record found.

News and Announcements icon
Community site session details

Community site session details

Session Id :
Business Central forum

Intelligent cloud data replication failed without error

(0) ShareShare
ReportReport
Posted on by

Hello everyone

We are trying out Intelligent Cloud as data migration solution, but we are having problems replicating data to cloud. Problem is that Intelligent Cloud setup is successful, new companies are created in cloud tenant, but when we try to replicate data it just fails without reporting any error.

We are using Microsoft self hosted integration runtime and have NL localization in cloud sandbox and installed Business Central CU2 NL localization on premise with demo database.

1st try we created BC cloud sandbox from official Business central page, uploaded extention to sandbox and to on premise BC. Showed that initialization was complete, new companies were created but when trying to replicate data it failed after 5 minutes without showing any error.

2nd try reset sandbox, created new nav users with SUPER permission sets, retried assisted setup and it worked, again initialization was successful and new companies were created but when trying to replicate data it failed without error.

3rd try tried running replication without integration runtime active, obviously it failed but it showed "error".

4th try created new custom company on BC on-premise and tried to replicate that data, again the results were the same, initialization successful, data replication failed.

5th try tried using different licenses. Result - same.

6th try uninstalled custom extentions. Result - same.

7th try tried different SQL connection string on setup. Wouldn't work at all.

8th try tried activating intelligent cloud on production cloud tenant. Result - same.

9th try gave all possible permissions to SQL database user witch is used in SQL connection string. Result - same.

10th try uninstalled all extentions except intelligent cloud extentions on both Cloud and on-premise business centrals. Result - same.

Each time Sandbox enviroment was reseted. Every time it showed that data replication failed but there were no errors shown. Total successful tables = 0 failed tables = 0. Testing connection to database on Integration Runtime Service shows that everything should be fine.
What might be the problem?

Categories:
  • Stefano Demiliani Profile Picture
    37,172 Most Valuable Professional on at

    Is your tenant upgraded to CU02 or it's on a different CU version? It must be with the same CU in order to have a successful synch.

  • Verified answer
    Community Member Profile Picture
    on at

    Figured out a problem. It turns out that demo database by default are created with compatability level of 110 instead of 130. So if someone has the same problem go to SSMS open properties of database that you're trying to replicate data from, go to options and check compatibility level.

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

November Spotlight Star - Khushbu Rajvi

Congratulations to a top community star!

Forum Structure Changes Coming on 11/8!

In our never-ending quest to help the Dynamics 365 Community members get answers faster …

Dynamics 365 Community Platform update – Oct 28

Welcome to the next edition of the Community Platform Update. This is a status …

Leaderboard > Business Central

Last 30 days Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans