Skip to main content
Dynamics 365 Community / Forums / Finance forum / Compiler does not disp...
Unanswered

Compiler does not display errors in the code

editSubscribe (0) ShareShare
ReportReport
Posted on by 69

Hello,

For some reason i can not get to work the real-time compiler on Visual Studio 2019. For testing purposes I create a new solution with a new project with only a class.

Everytime i Ctrl+S, it doesnt pop up the red lines with errors and I get this error message:

Error System.NullReferenceException: Object reference not set to an instance of an object.
at Microsoft.Dynamics.Framework.Tools.ILGeneratorAgent.CompilationService.ParseTypeResolve(String module, String metadataPath, String compilerMetadataPath, IEnumerable`1 referencedAssembliesFolders, IEnumerable`1 elements)

I tried build,rebuild, clean, create a new project, restart the AOS, etc.. I also read a post with same error years ago, so i checked that my version wasn't PU25. Actually is "Update55 (7.0.6651.143)".

I have a partner working on the migration from AX2012 that also has the same problem.. ¿Maybe we should try a model build?

Thanks in advance,

Eisenberk.