Skip to main content



No record found.

Dynamics 365 Community / Forums / Finance forum / Vendor Collaboration
Finance forum
Suggested answer

Vendor Collaboration

Posted on by Microsoft Employee

I have been trying to Configure Vendor Collaboration on the test Environment I have created the role for this vendor As an Vendor(External) and Vendor Admin(External). I have created the user for Vendor Collaboration at first, Vendor Collaboration user request was created and was waiting to approved. I then Configured Azure for B2B as per the following link:

My vendor collaboration still does not seem to working can you please help me.

The message I get on the Environment I created for vendor Collaboration: The user must have access to at least one user 

  • Ramit Paul Profile Picture
    Ramit Paul 18,426 Super User on at
    Vendor Collaboration
    When are you getting this error?
    At the time of login or in the workflow?
  • Shankar GR Profile Picture
    Shankar GR 56 on at
    Vendor Collaboration
    Step 1: Security configuration - External Vendor  & Vendor Admin (Role)
    Step 2 :Create the contact for the vendor.
    Step 3: Inviting by provision users 
    Step 4: B2B
    Step 5 : Activate the Vendor Collaboration toggle in the Vendor Card.
    User must have access to at  least ine user - You should add a contact to the particular vendor.
    If you have any questions I am happy to help you.
  • Anthony DG Profile Picture
    Anthony DG 7 on at
    RE: Vendor Collaboration

    The suggested answer worked for me!

    Vendor > General > Collaboration activation

    Set to "Active (PO is auto-confirmed)" or "Active (PO is not auto-confirmed)"

    Then I could access the various workspaces with my external user.

  • ThuNgo Profile Picture
    ThuNgo 972 on at
    RE: Vendor Collaboration


    In my case i have to check the Person assigned to user.

    Once you change the Person into Contact person for Vendor, it should work.



  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Vendor Collaboration

    The user must have access to at least one supplier

    I have the same issue.

    Contact in Supplier - Added

    user in azure - added

    user downloaded from Azure to System admin - user enabled, roles added:

    • Vendor (external)
    • External system user so they can use anything at all
    • Vendor admin external

    Still when provisioning the mentioned user, the roles are not showing in the 'assign user roles' list, however the tick box is active (???) (i ticked the box and created user but cannot activate it) and then I get a message error:

    ''The supplier collaboration access setting has been successfully applied. However, the request to create a new user account was not submitted successfully. Please contact your system administrator.''

    And this will probably give the 'user must have access...' error message later.

  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Vendor Collaboration

    have you enabled vendor for collaboration and have a vendor contact setup?

    see if this helps

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .


André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,835 Super User

Martin Dráb Profile Picture

Martin Dráb 225,526 Super User

nmaenpaa Profile Picture

nmaenpaa 101,148


Featured topics

Product updates

Dynamics 365 release plans