hi all,
i have a small problem here ... when evertime i used AR batch release... it will just hang in process process screen but the time duration for job processing got running .. without choice i use task manager to force to shut down but when i re-open the ar batch release in account receivable the job success release ..... any idea what happen about this matter ... above picture attach shows when click begin prcessing button.. it will show this error .. when press ok nothing happen and the duration for processing time still running ....
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Adam:
Do you have the FRx zip file? I'm having the same issue at one of my clients and can't seem to locate this "fix".
Hi Cory,
Below is the content to article 2551478.
System Message 6900, 6906, or 93 when you save or release a batch in Microsoft Dynamics SL 2011
Confidential Article
(The information in this article is provided to you per your Confidentiality Agreement.)
Article ID : 2551478
First Published: : 5/13/2011
Last Revised: : 5/17/2011
Revision : 1.0
Modification Type : Major
Language Locale : en-us
Article Status : Published Externally
Confidentiality : Partner
SYMPTOMS
When you save or release a batch in various modules in Microsoft Dynamics SL 2011, you may receive one or more of the following error messages:
System Message 6900 - Another process has updated the %s table. The system will automatically cancel your changes.
System Message 6906 - Another process has deleted the %s item. The system will automatically cancel your changes.
Server Message 93 - [Microsoft][SQL Server Native Client 10.0] Connection is busy with results for another command
CAUSE
This problem occurs if the Microsoft Dynamics SL Application database contains custom SQL triggers.
RESOLUTION
To correct this issue, add the following line of code to the beginning of any custom SQL triggers or of any stored procedures that you apply to the database.
set nocount on
Adam, we have recently upgraded to Dynamics 2011 and are experiencing the same issues. I don't see this article in Customer Source. I need the article to support our Change Management process. Do you have any suggestions?
The resolution in the first KB article outlined that this could possibly be caused by custom triggers in the application DB. To rule this out, can you please run the following against your app DB:
select * from sysobjects where xtype = 'tr'
Custom triggers typically start with 'x" to denote that they're not standard. In my standard windows auth DB, I see the following triggers:
EDPurchOrd_Insert
TrnsfrDocStatusUpdate
UpdateSOShipLotWithShipLine
ADG_TR_CustNameXref_Add
ADG_TR_CustNameXref_Delete
ADG_TR_InvtDescrXref_Add
ADG_TR_InvtDescrXref_Delete
INPrjAllocHistory_Insert
INPrjAllocTranHist_Insert
INPrjAllocLotHist_Insert
Delegation_Message_Trigger
Do you have additional, custom triggers in your app DB?
The second KB outlined an FRx fix B2551470_FRx_SL2011_93Fix.zip which you indicated that you applied. It's possible that this did not fully apply. Would you be able to re-open this script and re-run it against all of your application databases?
Once this is done, if you're still experiencing the errors, please let us know.
anyone can assist me for this problem ??? thanks
hi all.. about this ... i had used the solution with article ID : 2551470 ... i download the B2551470_FRX_SL2011_93_Fix.zip ... it solve the problem but everytime i first time boot up in the morning ... it came up the error message 93 again "ON VERY FIRST TIME ONLY ".. no choice i have to end the task again.. open the release ar batch... check it and it already release .. and i do the second time it completed withot error any more .. so the problem came on ONE TIME when i first time boot up the server and it came that problem agian and i hope do the end task thing on very first time .. after that no error at all for next batch release .. i also found that if i RESTART THE SQL SERVER , the error message came out again .. then i had to to the end task thingy again on every first time... ANY IDEA HOW TO SOLVE THIS issue ??? hope hear your reply soon and thanks again
Hello,
Please go to mbs.microsoft.com/customersource. There are documents you can download which explain how to gain access to your account on CustomerSource.
would u mind shows the details for article numbers " 2551478 " and " 2551470 " at here ???? thanks again
hi ,,,, thx for ur reply ... by the way how to i sign in to the customer source ???? i use my email account but the site shows invlaid email account in its database system
Hello,
You are not familiar with the Knowledge Base in CustomerSource? Click on Support | Knowledge Base. Here is a link to the articles: mbs2.microsoft.com/.../search.aspx
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