Skip to main content

Notifications

Business Central forum
Suggested answer

Error during asset creation

Posted on by 10
Hi all,
I get this error whenever I create a new asset and try to change the depreciation method from straight line to any other.
There is no trigger on depreciation method in page or table extension. There no other code that's related to that field. Not even testfield function on that field.
 
Depreciation Starting Date must have a value in FA Depreciation Book: FA No.=FAN007, Depreciation Book Code=DB. It cannot be zero or empty. in business central.
 
kindly assist
 
 
 
  • gdrenteria Profile Picture
    gdrenteria 4,046 Super User on at
    Error during asset creation
    Hi
    How do you make the change? And before what values ​​did the registry have?
    I ask this because, for example, here if I enter years of depreciation without entering the beginning, I get the error mentioned.
    BR
    GR
  • Suggested answer
    Valentin Castravet Profile Picture
    Valentin Castravet 6,122 Super User on at
    Error during asset creation
    Agreed with Yun Zhu, it doesn't cause any errors for me either. 
     
  • Suggested answer
    YUN ZHU Profile Picture
    YUN ZHU 62,529 Super User on at
    Error during asset creation
    Hi, I simply tested it and didn't encounter your problem.
    I suggest you debug it. Maybe it's caused by customization.
     
    Hope this can give you some hints.
    Thanks.
    ZHU

Helpful resources

Quick Links

Community Spotlight of the Month

Kudos to Mohamed Amine Mahmoudi!

Blog subscriptions now enabled!

Follow your favorite blogs

TechTalk: How Dataverse and Microsoft Fabric powers ...

Explore the latest advancements in data export and integration within ...

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,907 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,189 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,146

Featured topics

Product updates

Dynamics 365 release plans