Skip to main content

Notifications

Announcements

No record found.

Dynamics 365 general forum
Suggested answer

Chart colours not correct in D365 but are correct when editing Dashboard in Power Apps

Posted on by 54

Hi All

The problem is attached with screenshots. But basically I changed the Palettes to 'Berry' and 'Fire' in the charts xml and re-imported\updated the charts. The change shows when editing the dashboard in Power Apps but is still reverting to standard in D365 itself.

Please see the attached document.

Any ideas and suggestions to get this working properly would be greatly appreciaD365-Chart-colours.docxted.

  • SV-15060606-0 Profile Picture
    SV-15060606-0 2 on at
    Chart colours not correct in D365 but are correct when editing Dashboard in Power Apps
    I have the same problem on my funnel chart. Custom palette colors are displayed in the graph editor but not in the actual app.
    I  tried the manual xml editing and the XRMToolbox "advanced color editor" with no success
  • Suggested answer
    Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Chart colours not correct in D365 but are correct when editing Dashboard in Power Apps

    Hi MikeExeter,

    I added the Palette='Berry' to the xml of my chart and it couldn't work too. Then I edit the xml with 'Advanced Chart Editor' tool in the XrmToolBox and it can work.

    Please follow the steps:

    1. Open the visual editor of the chart.

    pastedimage1652410024650v1.png

    2.Click the chart and you would find that Palette is not supported.

    pastedimage1652410289717v2.png

    3. Click the Series, and you could change the color.

    pastedimage1652410385118v3.png

    4. Click the Save and OK

    pastedimage1652410446119v4.png

    5. Update your chart.

    pastedimage1652410475707v5.png

    6. Its color would be changed.

    pastedimage1652410506600v6.png

  • MikeExeter Profile Picture
    MikeExeter 54 on at
    RE: Chart colours not correct in D365 but are correct when editing Dashboard in Power Apps

    Hi

    Below is the xml - you will notice that I have even removed the PaletteCustomColors and have a Chart Palette of Berry:MH-_2D00_-Cases-by-SLA-Status-Over-Week-_2800_2_2900_.xml 

    <visualization>
    <visualizationid>{63a95bc6-a3cf-ec11-a7b5-6045bd0fc65f}</visualizationid>
    <name>MH - Cases by SLA Status Over Week</name>
    <description>Cases and SLA statuses, such as succeeded or violated.</description>
    <primaryentitytypecode>incident</primaryentitytypecode>
    <datadescription><datadefinition><fetchcollection><fetch mapping="logical" aggregate="true"><entity name="incident"><order alias="groupby_column" descending="false" /><attribute alias="aggregate_column" name="incidentid" aggregate="count" /><attribute groupby="true" alias="groupby_column" dategrouping="day" name="createdon" /><attribute groupby="true" alias="groupby_slastatus" name="resolvebyslastatus" /><filter><condition attribute="modifiedon" operator="last-seven-days" /></filter></entity></fetch></fetchcollection><categorycollection><category><measurecollection><measure alias="aggregate_column" /></measurecollection></category></categorycollection></datadefinition></datadescription>
    <presentationdescription><Chart Palette="Berry" PaletteCustomColors=""><Series><Series ChartType="StackedColumn" Font="{0}, 9.5px" LabelForeColor="59, 59, 59" CustomProperties="PointWidth=0.75, MaxPixelPointWidth=40" /></Series><ChartAreas><ChartArea BorderColor="White" BorderDashStyle="Solid"><AxisY LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount"><MajorGrid LineColor="239, 242, 246" /><MajorTickMark LineColor="165, 172, 181" /><LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" /></AxisY><AxisX LabelAutoFitMinFontSize="8" TitleForeColor="59, 59, 59" TitleFont="{0}, 10.5px" LineColor="165, 172, 181" IntervalAutoMode="VariableCount"><MajorGrid Enabled="False" /><MajorTickMark Enabled="False" /><LabelStyle Font="{0}, 10.5px" ForeColor="59, 59, 59" /></AxisX></ChartArea></ChartAreas><Titles><Title Alignment="TopLeft" DockingOffset="-3" Font="{0}, 13px" ForeColor="0, 0, 0" /></Titles></Chart></presentationdescription>
    <isdefault>false</isdefault>
    </visualization>

    I'll attach the xml as a file attachment too.

  • Community Member Profile Picture
    Community Member Microsoft Employee on at
    RE: Chart colours not correct in D365 but are correct when editing Dashboard in Power Apps

    Hi MikeExeter,

    Could you provide the XML of your chart for further research?

Helpful resources

Quick Links

Replay now available! Dynamics 365 Community Call (CRM Edition)

Catch up on the first D365 Community Call held on 7/10

Community Spotlight of the Month

Kudos to Saurav Dhyani!

Congratulations to the June Top 10 community leaders!

These stars go above and beyond . . .

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 287,986 Super User

#2
Martin Dráb Profile Picture

Martin Dráb 225,588 Super User

#3
nmaenpaa Profile Picture

nmaenpaa 101,148

Leaderboard

Featured topics

Product updates

Dynamics 365 release plans