Smartlist Error - Explorer_Get_DDL_Type not found

Question Status

Verified
Bill Campbell asked a question on 27 Jan 2014 1:31 PM

When opening Smartlist we encounter no issues, I have run GRANT.sql on all company databases as well as DYNAMICS.mdb

When I open Smartlist >> Project Accounting >> PA Contracts and select the default list - the data is cleanly presented.  When I then click the Search button on the bottom of the screen and enter 1 or more Search Definitions, and click on OK - I get the following:

Unhandled script exception:

Script 'Explorer_Get_DDL_Type' not found

Exception_CLASS_SCRIPT_MISSING

When I test this on Smartlist >> Project Acounting >> Pa Billing Open Transactions - click on Default, add a search definition, I get the new filtered data - no error.

So I am thinking it is something specific with the PA Contracts tables that are accessed in the PA Contracts Smartlist window.

I looked at Dynamics..ASIEXP81 and Dynamics..ASIEXP86 and did not find anything that made me go - got it - so I am reaching out to you my partners to see what we can figure out for this client.

In the mean time, I have to tell the client to 'not filter your 100,000 records to find what you need, all the while he is laughing out loud and smiling - not so warmly at me.  

Help.

Reply
Almas Mahfooz responded on 31 Jan 2014 3:11 AM

Yes It seems upgrade issue to me.

Did you also run the setup on your client machines?

Do you have separate GP folder for GP10 and GP2013.

Also I tried to find this script in GP10,2010 and 2013 but didn't find this specific script Explorer_Get_DLL_type, instead I found Explorer_Get_Datatype in GP2013.See screen shot below.

Could you share your error screen shot here?

Reply
Almas Mahfooz responded on 31 Jan 2014 3:24 AM

Bill can you record a macro file (just to record the part when you open troubled favorite smartlist) and share here?

Reply
EpicAbby21 responded on 5 Feb 2014 1:47 PM

Has a resolution been reached for this?  I also have an issue with this.  How do you recreate the PA_Smartlist objects?

Reply
Judith Carson responded on 5 Feb 2014 2:05 PM

Hi

To remove PA smartlist business objects go to Tools>>Utilities>>Project>>Remove PA Smartlist and to add them Tools>>Utilities>>Project>>Install PA Smartlist.

Deleting and recreating the PA Smartlist objects does not solve this problem.  My GP support person is reporting this as a bug in 2013 so I am still waiting on the outcome.

Judi

Reply
EpicAbby21 responded on 5 Feb 2014 2:10 PM

Thank you for replying Judi, very helpful!  I hope there is a resolution soon!

Reply
Almas Mahfooz responded on 5 Feb 2014 9:29 PM

EpicAbby21 what is your go version? what sp is it?

Reply
Almas Mahfooz responded on 5 Feb 2014 9:33 PM

Judi, what's your GP version?

I have GP 2013 and I am not getting issue with filters.

Reply
Judith Carson responded on 5 Feb 2014 9:43 PM

GP2013 SP2 - As stated before it is only the STATUS filter not any of the others.

Judi

Reply
EpicAbby21 responded on 6 Feb 2014 6:53 AM

Same version and same issue as Judi.

Reply
EpicAbby21 responded on 6 Feb 2014 7:01 AM

Judi - do they have bug number for this?  Just wondering if I should submit my case as well, normally the more people with the issue the quicker turnaround.  Thanks!

Reply
Almas Mahfooz responded on 7 Feb 2014 1:47 AM

Bill,

After checking this on GP2013 SP2, I also got the error.

Here I am sharing workaround for filtering on PA Status or any other DDL field of PA Contracts SmartList, see if it is workable for you.

There are some User defined fields in PA Contracts table and if you are not using them or have at least one of them available, then use below SQL query to update PA Status in this UD field.
--select PAUD1_Cont,PASTAT,* from PA01101

update PA01101 set PAUD1_Cont=PASTAT

On SmartList, just remove PA Status field  from * .

 

now move up User defined 1 and rename it to PA Status.

 

Now add filter to PA Status to the value you are looking, for example 4.

                                           

Now add it as a favorite.

 

Reply
Almas Mahfooz responded on 7 Feb 2014 1:48 AM

Also see below numeric values of PA Status:

1 = Open

2 = On Hold

3 = Closed

4 = Estimate

5 = Completed

Reply
EpicAbby21 responded on 7 Feb 2014 8:02 AM

Hi Almas,

Thank you for providing the workaround however, I am using PA Projects.  I notice there are Two User-Defined fields for this instance as well.  But my client is using those fields for other information.  Is there any other field that can be used to track the PA Status for Smartlists?

Reply
Bill Campbell responded on 7 Feb 2014 11:40 AM

While this is a nice work around if you did not have a couple 1000 projects that now you have to manually update when you change the status.

I might be able to make this work, unless the client is using the fields for something else - which is a very good possibility at they have a limited number of fields with which to record information that they require.

Not sure I understand why Unloading the PA Smartlist objects does not fix this - is this something that is missing for EVERYONE - surely we can not be the only companies that are experiencing the issue on the Filter of PA Contracts by PA Status

Thanks for the work around, but I am holding out for a FIX to the issue.

Reply
Almas Mahfooz responded on 8 Feb 2014 12:20 AM

Bill are you using SUTA State and Worker's Com fields?

You can use SUTA state field.

select PAUD1Proj,PAUD2_Proj,SUTASTAT,WRKRCOMP,* from PA01201

 

also check  LOCATNID field.

select LOCATNID,* from PA01201

Reply
Verified Answer
Bill Campbell responded on 27 Jan 2014 2:18 PM

Yes, it happens to ALL users - on ALL workstations

What I have done so far is to remove any of the records that contain some form of Search Criteria.  Once those are removed then the system seems to work.

I only looked at Dictionary 258 = Project Accounting = when the lines were removed from the ASIEXP81 table then the query for the rest of the table defaults seems to work correctly.

Thanks for your time (so far on this matter)

Reply
Suggested Answer
Gary Letter responded on 8 Apr 2015 9:08 AM

The following worked for our customer who had just upgraded to GP 2013 R2. They were seeing this error with all the SmartLists under PA Projects.

1. Select the Smartlist folder PA Projects
2. Click the Modify button. This customer has Smartlist Builder, so the SLB window opens.
3. Give it a new SmartList Name and a new Item Name.
4. Click Save.

Even when I change the names back to the original names, the lists appear to run properly with no error message. You may have to re-save individual SmartLists if you are not getting the results you expect; enter the search criteria again and click Modify.

Thanks,
GCL

Reply