SBX - Search With Button

SBX - Forum Post Title

Multicurrency

Microsoft Dynamics GP Forum

Tucker asked a question on 12 Oct 2017 11:14 AM
My Badges

Question Status

Verified

Getting the following error(s) on the GL edit list:

The currency ID is missing.

The rate type ID is missing.

The exchange table ID is missing.

I checked the setup and it appears to be correct (Mirroring other companies that are not having this issue.) I ran checklinks on the multicurrency logical tables. Can't seem to isolate the problem. Any assistance is greatly appreciated.

Reply
Tim W responded on 12 Oct 2017 1:52 PM
My Badges

I've not encountered this error but wondering if you enabled MC while you had unposted GL transactions or you have an integration that is not setting the functional currency.  Gl10000 (GL header work) would have these fields and I think if functional currency id is missing or wrong I'd see where it might throw your error.

Maybe checklinks on all finance work tables might help.

Reply
Tucker responded on 13 Oct 2017 8:41 AM
My Badges
Verified Answer

Tim,

Thank you for your insight. I figured out the issue. We are using SmartConnect with the GL integration. The none of the GP companies in question have a checkbook ID or item assigned to the currency ID. By going into the individual transactions and selecting the currency ID the errors are resolved, but the long-term resolution is to setup a checkbook ID with the currency ID assigned to it.

Reply
Tucker responded on 13 Oct 2017 8:41 AM
My Badges
Verified Answer

Tim,

Thank you for your insight. I figured out the issue. We are using SmartConnect with the GL integration. The none of the GP companies in question have a checkbook ID or item assigned to the currency ID. By going into the individual transactions and selecting the currency ID the errors are resolved, but the long-term resolution is to setup a checkbook ID with the currency ID assigned to it.

Reply

SBX - Two Col Forum

SBX - Migrated JS