Question Status

Unanswered
JimK asked a question on 24 Apr 2013 7:38 AM

I have imported a few dozen transactions via econnect that seemed to work fine. However, now it comes time to transfer these orders to invoice, but it won't work. GP reports no errors, but also reports 0 orders transferred. I have since successfully imported more transactions that do invoice and eventually post just fine. So I am wondering how to find out why this handful won't transfer to invoice. They all have PO's attached, so they can't simply be re-entered (can they?) Any ideas?

Reply
AdamH responded on 30 Apr 2013 10:29 AM

Hi Jim,

On these transactions that won't transfer, I would check to see if all the reqiired fields are filled in.

I have seen it before where a required field won't be filled in by eConnect but because the transfer process needs it it causes the problem you are seeing.

I would also verify that the inventory is allocated/fulfilled as you expect.

When I have had these problems before I usually go to the GP screen itself and open/close all the windows and make sure it saves ok and have often found the problem that way.

If that does not work, I would suggest selecting a good order and bad order from teh database into Excel and compare the fields to see what might be missing.

Another way to troubleshoot this is to try and import one of your transactions as an invoice instead of an order and see if it gives you an error in eConnect or a posting error in the Batch Edit Report for the invoice.

Usually it comes down to some field(s) not being filled in and eConnect not throwing an error.

Let me know if I can get you any other info.

Thanks,

Adam

Reply
Dave Dusek responded on 1 May 2013 6:49 AM

Check the Qty fields.  Make sure that you have a Qty to invoice populated on the line items.  If you have Qty to bko populated for example, you can transfer all you want but you will get no errors and the invoice won't be created because there are no qtys to transfer.  

Reply
Jim K responded on 6 May 2013 10:47 AM

I have checked and all the quantity fields are there that are filled in from a GP UI entered transaction with identical line item. They are both fulfilled, nothing on PO, entire qty to be invoiced. The sales transaction window seems to have no problem with display, editing, or saving the transactions in question, and PO's were generated.

Might there be some other table that didn't get written to? What tables get that SOPNUMBE records for an order and a PO besides SOP10100 and SOP10200?

Thanks...causing a lot of grief....

Reply
Dave Dusek responded on 6 May 2013 12:18 PM

Are they drop ship line items or anything like that?  Drop ship lines won't transfer to an invoice until the purchase order has been received if you try it after generating po's.  Other than that, it shouldn't be checking any other tables.  If there was a process hold, it would say that on the report, so I don't think it's that.  May want to try to get a dexterity script log so you can see what scripts are running and then compare a good vs bad.  

Reply
Ian Stewart responded on 7 May 2013 3:34 AM

Is the Order Type field the same on good and bad transactions? (if not make it so and reintegrate the order) - see what happens.

You should be able to get a bad order to transfer. Play with the quantity fields - run an allocation / fulfill etc. Process a manual inventory increase adjustment for all of the items on the order.

Are the item numbers the same on good and bad transactions?

If not - are these serial number or lot tracked items?

Check the Item Type - is it Inventory / service / Miscellaneous fees etc.

Try entering a bad transaction manually - exact same data.

Ian Stewart MVP - International support for Dynamics GP. Local knowledge, local timelines, local GP talent. Genesys Financial Systems (Europe) Microsoft Gold Certified Partner http://dynamicsgp.wordpress.com/

Reply
AdamH responded on 7 May 2013 11:09 AM

Hi Jim,

Have you tried taking a good transaction and a bad transaction with one item on each and exporting the SOP10100 and SOP10200 lines to Excel and then identifying any fields where they are different?

When I had this issue before, that was the easiest way. Once you know the fields that are different you can isolate which one may be causing the problem.

If you need any additional help on this send me an email and I can walk through some of the troubleshooting with you.

Hope this helps,

Adam

Reply
Jim K responded on 3 Jun 2013 8:40 AM

By way of update, I have given up on trying to transfer these transactions to invoice. There is no difference in the data fields in the standard SOP tables, and even the other handful of tables that record commissions, etc, which I have listed below for anyone interested in all the possible tables that a working sales transaction can update/insert--but most of which, in my system at least, aren't used at all.

Anyway, my solution is to void the orders, re-enter through e-Connect as invoices, and then post from there, thus avoiding the transfer process all together. So, no answer as to why, but I sure as hell can't find it, and have tried everything and more that has been suggested!

Thanks for the great feedback,

Jim

SOP10100

Sales Transaction Work

SOP10101

Sales Commissions Work and History

SOP10102

Sales Distribution Work and History

SOP10103

Sales Payment Work and History

SOP10104

Sales Process Holds Work and History

SOP10105

Sales Taxes Work and History

SOP10106

Sales User-Defined Work History

SOP10107

Sales Tracking Numbers Work History

SOP10108

Extended Pricing Price Group Header

SOP10109

Extended Pricing Price Book Header

SOP10110

Extended Pricing Price Sheet Header

SOP10111

Sales Picking Instruction Master

SOP10112

Sales Workflow Work and History

SOP10200

Sales Transaction Amounts Work

SOP10201

Sales Serial/Lot Work and History

SOP10202

Sales Line Comment Work and History

SOP10203

Sales Order Bin Quantities Work and History

SOP10204

Extended Pricing Promotion Work

SOP10205

Extended Pricing Price Book Work

SOP10206

Sales Bulk Print Header

SOP10207

Sales Bulk Print Line

Reply