Question Status

Suggested Answer
Imad Kassoumah asked a question on 27 Oct 2013 12:07 AM

Business Analyzer giving an error "Could not connect to configuration report" in GP2010 and GP2013.

It was working fine in GP10.

SSRS is working fine in GP2010 and GP2013.

Business Analyzer is working fine within GP2013 Home Page.

Thanks.

Imad Kassoumah

Reply
Sanjay Kumar Rajarao responded on 27 Oct 2013 11:38 PM

Imad,

Did you try resetting business analyzer ?

dynamicsgpblogster.blogspot.com/.../how-to-reset-business-analyzer-settings.html

Cheers!

Sanjay

Sanjay Kumar Rajarao. ACA, MCP

http://www.sanjaykumar.us |  sanjay.rajarao@live.com 

 

Reply
Imad Kassoumah responded on 28 Oct 2013 2:32 AM

Hi Sanjay,

Yes I did, even I re-installed but still the same error.

Reply
Rob Bernhardt responded on 30 Oct 2013 1:37 PM

Imad,

What part of the Business Analyzer is giving you this error?  (Is this during the install or later?)

With the same machine and user, can you access the URL that is being used for the Business Analyzer?

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Imad Kassoumah responded on 31 Oct 2013 12:24 AM

Hi Rob,

It's giving the error every time I start Business Anaylzer. The installation is working fine without any problem.

Once I get the error I have just to click on "Yes". After that I'm getting another error "Error loading roles", I click on "Yes" then the system is working fine. I'm able to select and run the Reports as normal.

This is happening on the server and the client for GP2010 and GP2013.

Thanks.

Reply
Rob Bernhardt responded on 31 Oct 2013 7:34 AM

Imad,

I believe the Business Analyzer is looking for the configuration report.  Please check the root of your report server path and see if it exists.  Another thing you could do is check the report server log and see what is being requested when the Business Analyzer gives the error.

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Imad Kassoumah responded on 2 Nov 2013 11:59 PM

Hi Rob,

Could you please tell me the name of the configuration report. I have rsreportserver.config.

I checked the report server log file and found the following error:-

"library!ReportServer_0-18!440!11/03/2013-08:13:13:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.WrongItemTypeException: The operation you are attempting on item "/" is not allowed for this item type., ;

Info: Microsoft.ReportingServices.Diagnostics.Utilities.WrongItemTypeException: The operation you are attempting on item "/" is not allowed for this item type.

library!ReportServer_0-18!440!11/03/2013-08:13:20:: Call to ListChildrenAction(/, False).

library!ReportServer_0-18!440!11/03/2013-08:13:20:: Call to ListChildrenAction(/, True).

library!ReportServer_0-18!440!11/03/2013-08:13:26:: i INFO: RenderForNewSession('/COIL/Sales/Charts And KPIs/Receivables Summary')

library!ReportServer_0-18!6bc!11/03/2013-08:13:26:: i INFO: RenderForNewSession('/COIL/Sales/Charts And KPIs/Receivables Summary')"

I would like again to mention that the reports are working fine winthin Business Analyzer after clicking Ok on the two error messages. They are also working winthin GP Home page and IE.

Thanks a lot.

Imad Kassoumah

Reply
Suggested Answer
Mariano Gomez responded on 3 Nov 2013 11:14 AM

I've seen Business Analyzer throw this error when the SRS connections are set to use SQL security, as opposed to Windows integrated security. Verify your report connections and switch them to use Windows Integrated Security.

Best regards,

MG.-
Mariano Gomez, MIS, MVP, MCP, PMP
IntellPartners, LLC
Blog: http://dynamicsgpblogster.blogspot.com

Reply
Imad Kassoumah responded on 3 Nov 2013 10:30 PM

Hi,

The error messages are displayed even if there is not yet any selected reports.

I changed SQL security to windows for ReportServer database, I'm still getting the same errors.

As I said the reports are working fine after getting the errors.

Regards.

Reply
Rob Bernhardt responded on 4 Nov 2013 9:08 AM

Imad,

It's simply named ConfigurationReport.  It should be located at the root of your report server url.  Another related question:  Does your role dropdown fill and provide role selections in the configuration area?

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Imad Kassoumah responded on 4 Nov 2013 10:21 PM

1104.Business_Analyzer.rarHi Rob,

The second message "error loading roles" is displayed. I'm unable to access the role field.

You can notice on the attached snapshot  Connecting to Server, it does not change. This note does not happen on GP2013.

You mentioned that it's simply named Configuration Report, would you please give me the file name that the system is looking for?

Best regards.

 

Imad

Reply
Rob Bernhardt responded on 5 Nov 2013 6:50 AM

Imad,

The name of the report is "Configuration Report".  It is deployed by Dynamics GP, and it provides a list of roles, role/report assignments, etc.  You should find it at the root of your report server URL.  If it's not there, that would explain the two error messages you mention.  

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Imad Kassoumah responded on 5 Nov 2013 11:28 PM

Hi Rob,

I could not find this report file. I uninstalled Business Analyzer and GP 2010 on the server then reinstalled them. Still this file does not exist on the server.

Business Analyzer was not giving this error on the previous release!!

Is there a way to create it?

Regards.

Reply
Rob Bernhardt responded on 7 Nov 2013 9:08 AM

Imad,

What version of GP 2010?  In GP 2010 R2 and greater, this report is deployed from Dynamics GP.  Earlier releases required the srs deployment wizard.

Tools > Setup > System > Reporting Tools Setup will deploy the reports.

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Imad Kassoumah responded on 10 Nov 2013 3:54 AM

Hi Rob,

This issue is happening on GP2010 R2 (SP3) and GP2013 SP2.

As I said the reports are deployed and working fine from IE , GP and Business Analyzer.

Business Analyzer is only giving these messages at the satrt-up or when going to change the selected reports.

Regards.

Imad.

Reply
Rob Bernhardt responded on 11 Nov 2013 6:39 AM

Imad,

Based on what you've described, I'm guessing it's an issue with the configuration report.  "ConfigurationReport.rdl" should exist at the root of your report server url.  It provides the roles, which you described as being unavailable.  If re-deploying the reports doesn't fix the problem, I'd suggest talking to support to resolve your issue.  

Good luck!

Thanks

Rob

Rob Bernhardt [MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Suggested Answer
Mariano Gomez responded on 3 Nov 2013 11:14 AM

I've seen Business Analyzer throw this error when the SRS connections are set to use SQL security, as opposed to Windows integrated security. Verify your report connections and switch them to use Windows Integrated Security.

Best regards,

MG.-
Mariano Gomez, MIS, MVP, MCP, PMP
IntellPartners, LLC
Blog: http://dynamicsgpblogster.blogspot.com

Reply