SBX - Search With Button

SBX - Forum Post Title

GP2016 Web Client stuck at Microsoft Dynamics GP" screen

Microsoft Dynamics GP Forum

TracySam asked a question on 26 Jun 2017 4:01 PM

Question Status

Suggested Answer

I installed the GP2016R2 Web Client but the screen is stuck on "Microsoft Dynamics GP" after the initial login screen.  How can I fix this ?

Reply
TracySam responded on 26 Jun 2017 4:30 PM

The error logs contains the following error :

Correlation ID: d65e0191-ccc3-4604-8612-941a7dbd3600 System.Web.HttpException (0x80004005): Cannot redirect after HTTP headers have been sent. at System.Web.HttpResponse.Redirect(String url, Boolean endResponse, Boolean permanent) at System.Web.HttpResponseWrapper.Redirect(String url, Boolean endResponse) at System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList`1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) at System.Web.Mvc.ControllerActionInvoker.InvokeActionResultFilterRecursive(IList`1 filters, Int32 filterIndex, ResultExecutingContext preContext, ControllerContext controllerContext, ActionResult actionResult) at System.Web.Mvc.ControllerActionInvoker.InvokeActionResultWithFilters(ControllerContext controllerContext, IList`1 filters, ActionResult actionResult) at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass21.<BeginInvokeAction>b__1e(IAsyncResult asyncResult) at System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeAction(IAsyncResult asyncResult) at System.Web.Mvc.Controller.<BeginExecuteCore>b__1d(IAsyncResult asyncResult, ExecuteCoreState innerState) at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) at System.Web.Mvc.Controller.EndExecuteCore(IAsyncResult asyncResult) at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) at System.Web.Mvc.Controller.EndExecute(IAsyncResult asyncResult) at System.Web.Mvc.MvcHandler.<BeginProcessRequest>b__5(IAsyncResult asyncResult, ProcessRequestState innerState) at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncVoid`1.CallEndDelegate(IAsyncResult asyncResult) at System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Reply
Béat Bucher responded on 27 Jun 2017 9:20 AM
Suggested Answer

Hi,

When you say "...after the initial login screen..." do you mean the network/AD  authentication ? Was that a brand new setup of the Web client or an upgrade ? did you fired up the GP Utilities on the server side to specify which accounts to use for the Web Services ? Have you made sure your GP user logins are associated with the proper AD user-id ?

Reply
TracySam responded on 3 Jul 2017 3:02 PM

After I enter the network user ID and password then the Microsoft Dynamics GP window appears and does not go away.  This is a brand new setup of the web client.  I had setup a sql  account in GP Utilities to be used for accessing the web client and I have associated the sql accounts with an AD user id.

Reply
Béat Bucher responded on 4 Jul 2017 9:58 AM
Suggested Answer

Hi Tracy,

During the Web client service setup, did you install a proper SSL certificate ? this is mandatory to work, though the documentation says it's not required if you intend to use the web client locally on the intranet only.. I tried that and it failed.. I had to restart the whole process and provided a self-signed certificate for the local server.

Reply
TracySam responded on 7 Jul 2017 3:29 PM

I reinstalled the Web Client using a self signed certificate but I am having the same problem where the GP login screen does not appear.  The user I am logged in as is setup in user setup.

Reply
mscottsinclair responded on 7 Dec 2017 11:07 AM

Are you still having this issue?  I found that on my server using just the server name (https://servername/GP) worked fine but from the workstations I had to use the FQDN of the self signed cert (servername.domain.local/GP).  This solved the issue for me in Chrome and IE.

Reply
Béat Bucher responded on 27 Jun 2017 9:20 AM
Suggested Answer

Hi,

When you say "...after the initial login screen..." do you mean the network/AD  authentication ? Was that a brand new setup of the Web client or an upgrade ? did you fired up the GP Utilities on the server side to specify which accounts to use for the Web Services ? Have you made sure your GP user logins are associated with the proper AD user-id ?

Reply
Béat Bucher responded on 4 Jul 2017 9:58 AM
Suggested Answer

Hi Tracy,

During the Web client service setup, did you install a proper SSL certificate ? this is mandatory to work, though the documentation says it's not required if you intend to use the web client locally on the intranet only.. I tried that and it failed.. I had to restart the whole process and provided a self-signed certificate for the local server.

Reply

SBX - Two Col Forum

SBX - Migrated JS