SBX - Search With Button

SBX - Forum Post Title

GP 2013 R2--After update from RTM quick links are missing from the homepage

Microsoft Dynamics GP Forum

Kaylasch asked a question on 4 Jun 2018 5:18 PM

Question Status

Unanswered

Hello,

After updating to GP 2013 R2 from RTM, some users have lost visibility to their quick links in the navigation page. the hot keys still work but are not visible. I have found some blogs with temp solutions such as copy home page settings. Is there a permanent fix, or script I can run to fix this issue?

Regards,

Kayla

Reply
Derek Albaugh responded on 5 Jun 2018 7:28 AM
My Badges

Hello Kayla,

When you state that the users have lost visibility to their Quick Links in the navigation page, are you meaning the 'Quick Links' section on the GP Home Page or something else?

If it is the Quick Links section on the Home Page, usually that is controlled by the SY08100 table, which you've probably found scripts on. From what I can tell, the SY08100 table value of 5 in the SectionID column is for Quick Links, if the entire section is not visible.

Each user should have about 8-9 records in this table for each section of the Home Page, whether visible or not. The 'Visible' column dictates whether the section is seen or not.

Other tables that work with menus and such are the SY07121, SY07125 and SY07110.

That being said, I'm curious as to why it's only some users, as normally if there was an issue with Dynamics GP it would affect all users, but that doesn't seem to be the case.

Are all users accessing the same Dynamics GP code, such as in a terminal server environment, or do they each have their own installs of GP? Third party products in play?

There really isn't a permanent fix, as we don't normally see this happen, which is why there really only are scripts to replace any missing records in the SY08100 table to resolve the issue of Quick Links missing or other sections of the Home Page.

The only other thing I can mention is that we have seen behavior such as this when users launch the GP application and start clicking on things before the application is fully loaded. Make sure that when they launch GP, they're waiting till the application loads fully, i.e. the user id and date at the bottom of the application show as filled in or black, and not grayed out/disabled and all the menu options across the top show, such as Inquiry, Transactions, Reports, Cards, etc.

Let's start with this and see what else we can find. I did find a couple of cases that mentioned a possible 'bug' with the Quick Links, but can't find anything on it to be sure, but I'll keep looking.

Thanks

Reply
Kayla Schilling responded on 5 Jun 2018 1:34 PM
My Badges

Hello Derek,

I will check the user that was reported, and get back to you with results. Thank you!

Reply
Kaylasch responded on 13 Jun 2018 4:10 PM

Hello Derek,

I confirmed that the quick links area of the homepage is set to visible and the SY08100 for the user looks good as it has 8 rows. I confirmed with the customer that it is the shortcuts area of the navigation pane that is missing the shortcuts. The hot keys for them still work, but they are not visible. I logged in with that user in their GP 2018 test upgrade environment, and I see that there are shortcuts visible in the navigation pane. The SY01990 in GP 2013 R2 and GP 2018 are pretty much the same for the user that is affected. I am waiting on confirmation from the customer if it is working on 2018, and not 2013 for that specific user. The customer doesn't believe that all users are affected.

Reply
Kaylasch responded on 18 Jun 2018 1:54 PM

Hello Derek,

I have confirmed that in 2013 the shortcuts in the nav pane are missing for the user, but in 2018 they are there. They have 103 shortcuts so it would be difficult to recreate them. and they are not going to have the production upgrade for a couple of months. Is there anything I can do to make them visible? They are still in the table for GP 2013 R2.

Reply
Derek Albaugh responded on 18 Jun 2018 2:55 PM
My Badges

Hello Kayla,

Creating two navigation shortcuts on the GP home page, it appears only the SY01990 table is used to hold this information. By default the user(s) should have about 9 default records in this table for the other shortcuts such as Startup, My Reports, All Reports, Custom Reports, User Preferences, etc.

When I added my two shortcuts, one a SmartList report and one a GP window, it added one record each in the SY01990 table and nothing really stands out other than they had a scbShortcutKey of 2161 and 2416 for the F2 and Shift + F1 hot key I put for these two shortcuts, then the ScbTargetLongOne holds the dictionary / product ID for the products I'm working with such as 1493 for the SmartList report.

Other than that, no other tables are really used at least what the dexsql.log is showing written to.

If I understand, the SY01990 table in both GP 2013 and GP 2018 show the exact same records for this user, but in GP 2013, this user doesn't see the shortcuts, but in GP 2018 they are there?

Looking through our case history and forums, other than seeing some issues with 3rd party products in mostly older versions of GP, (i.e. 10 and 2010), we really haven't seen this issue in newer versions, which we obviously would if it was some type of defect with our upgrade or anything such as that.

Some things to verify if you haven't already:

1. If users have their own GP installs on their own workstations, if this one user goes to another machine and logs into GP, does their shortcuts still not appear as expected? At the same time, if another user goes to this one user's machine and logs into GP, do they see their shortcuts fine?

2. If this is a terminal server environment where all users access the same GP install, and if so, have we tried a 'clean' install with no 3rd party products at all or customizations?

3. Is it only the one user that is experiencing this issue or more?

4. Also, are we going through any type of Citrix or RemoteApp environment and/or using roaming profiles at all (i.e. each user has their own Dynamics.set or Dex.ini files used when launching GP)?

I'm not sure if there is a way to get the shortcuts visible again if the information is all in the SY01990 table the same in GP 2013 as in GP 2018, but the shortcuts show in GP 2018 and not in GP 2013, as there isn't any type of 'visible' value or column in this table at all.

Even more odd is that between GP 2013 and GP 2013 R2, the SY01990 table isn't actually upgraded, so how it somehow lost data in the prior or new version is strange in itself, as this table shouldn't actually be touched at all during the upgrade process. Now, when upgrading to GP 2018 from GP 2013 R2, this table does get upgraded (at GP 2015 R2) so it would go through an upgrade process, but even then, normally the way Utilities handles tables being upgraded, it's very rare that we would ever lose data during an upgrade process.

If it were a case where the shortcut information was missing from the SY01990 table in GP 2013 R2 after upgrading from GP 2013 or in GP 2018 after upgrading from GP 2013 R2, I'd say to copy the information into this table manually, but so far I haven't seen this behavior exist in case volume, though I guess I've never actually tested it myself.

Thanks

Reply

SBX - Two Col Forum

SBX - Migrated JS