Update October 2018.

I see many people is reading this post and notice that is outdated: now the improvements are important, and this is very simple. I will follow the steps with a local NAV 2018 for download symbols and start working with VSCODE.
Step 1.
Still watch Developer services Enabled is checked, in NAV service management.
Step 2.
Open Visual Studio Code, press F1 and write AL: Go!. Select Localhost Instead Sandbox:
Step 3.
Check this lines in App.json files:
  "platform": "11.0.0.0",
  "application": "11.0.0.0",
And Launch.json:
            "serverInstance": "DynamicsNAV110",
            "authentication": "Windows",
And you´ll see symbols downloaded (pressing F1+Download Symbols):
[2018-10-06 15:41:17.21] Sending request to http://localhost:7049/DynamicsNAV110/dev/packages?publisher=Microsoft&appName=System&versionText=11.0.0.0
[2018-10-06 15:41:17.45] All reference symbols have been downloaded.
Roll.

All bellow has been kept as historic documentation.

Outdated!!!! Starting with AL: Frequent issues (mostly with download symbols).

When I started with AL, with a local installation from product DVD, I have seen some issues and I have noticed too, that a lot of people have the same issues and not too easy to fix them with the forum answers. Well, I am a programmer, but not a very technical programmer. So I think my experience could help someone to start using AL with VSCode.

Steps to begin.

This is the beginning: I just installed NAV 2018 form DVD, you can follow steps showed in this post: https://community.dynamics.com/nav/b/totovicnavblog/archive/2017/12/03/how-to-install-nav-2018. I didn´t have the problem about Developer services Enabled not checked, but is good to open the service management and make a review.

Next step, if you haven´t already did it, download and install Visual Studio Code. Go to https://code.visualstudio.com/ and it´s very easy, even for people like me.

The next step is open VSCode and install AL language extension. There are two ways to do that, and I think the right is the second (later you will notice why):

  1. Go to extensions and install AL from Market place.
  2. Press F1, search install extensions from vsix file and select ALLenguage.vsix from your local PC. I think this is right option, because this fix one of the most frequent issues: can´t download symbols.

 

Next step type Al Go to load a new AL sample project.

 

To make it work, we have to do:

1. Download symbols.


2. Publish with F5.

First problem: Server not found.

This could be fixed editing in launch.json this line, setting tenant to an empty string.:

tenant: ””,

Can´t download symbols.

When we type download symbols we have an output asking you to review setup in app.Json and launch.json , and symbols can´t be downloaded:

So, you can do two actions:

Edit app.json and set locale from US to W1. W1 allways work:

locale: W1

Install AL language extension form DVD instead from Market place. Remember:


And then you choose the ALLanguage.vsix from your computer.

I hope this could be useful. If you are some questions please send it to me, but notice I am very basic solving problems.