SBX - Search With Button

SBX - Forum Post Title

Data Increases Automatically

Microsoft Dynamics NAV Forum

ola123 asked a question on 11 Oct 2017 8:16 AM

Question Status

Suggested Answer

Hi Everyone,

Microsoft dynamics NAV database increases automatically and hit up the space of the virtual server.

Kindly help.

Reply
Zaid Tariq responded on 11 Oct 2017 1:27 PM
My Badges
Suggested Answer

Hi,

Try deleting the database log file.

Reply
Disu Ridwan responded on 11 Oct 2017 2:26 PM
My Badges

If we delete the database log file, Will the database still available to work with.

Reply
Zaid Tariq responded on 11 Oct 2017 2:34 PM
My Badges
Suggested Answer

Please have a look at the thread here: https://stackoverflow.com/questions/996403/disable-transaction-log

Reply
Francisco Bedolla responded on 11 Oct 2017 6:14 PM
My Badges

with one customer, somebody truncate the log and the system was broke.

its better to make a maintenance job

Perform a full backup of your database. Don't skip this. Really.

Change the backup method of your database to "Simple"

Open a query window and enter "checkpoint" and execute

Perform another backup of the database

Change the backup method of your database back to "Full" (or whatever it was, if it wasn't already Simple)

Perform a final full backup of the database.

Shrink the Log file

this needs to be run everyday to get a full backup for the last 24 hours

the log is used  by the DBA´s to recover a DB restoring the last full, then the differentials and the log to the last operation prior the error, so is a very impressive and specialized job. if you dont have a DBA or you dont mind to  lose the last day operations, you can use the simple recovery model and full daily.

Reply
Zaid Tariq responded on 11 Oct 2017 6:44 PM
My Badges
Suggested Answer

You need to make the database offline first then you can be able to delete, else data will be corrupted.
- Also make sure the Change Log is not enabled in NAV

Reply
Manish Sharma responded on 12 Oct 2017 12:00 AM
My Badges

You should setup a schedule in SQL to automatically shrink the database & log file.

Reply
Disu Ridwan responded on 12 Oct 2017 2:06 AM
My Badges

Thank you all. Will work on that and get back to you.

Reply
Zaid Tariq responded on 11 Oct 2017 1:27 PM
My Badges
Suggested Answer

Hi,

Try deleting the database log file.

Reply
Zaid Tariq responded on 11 Oct 2017 2:34 PM
My Badges
Suggested Answer

Please have a look at the thread here: https://stackoverflow.com/questions/996403/disable-transaction-log

Reply
Zaid Tariq responded on 11 Oct 2017 6:44 PM
My Badges
Suggested Answer

You need to make the database offline first then you can be able to delete, else data will be corrupted.
- Also make sure the Change Log is not enabled in NAV

Reply

SBX - Two Col Forum

SBX - Migrated JS