SBX - Search With Button

SBX - Forum Post Title

A Transfer Order doesn't post. What settings are lacking ?

Microsoft Dynamics NAV Forum

Raoul Bertorello asked a question on 5 Feb 2018 5:33 AM
My Badges

Question Status

Verified

Navision 2016

Cronus example db (Spanish settings)

I filled in a sales order with a Posting/Order/Document Date on today, 5 Feb, in the General section for a certain number of a single item to be picked up at a newly created location, that was not yet existing in the example db so that I made it on purpose, and a Requested/Promised Delivery Date on 6 Feb, tomorrow, still in the General section.

I created the new location with a single empty bin, therefore I also created a transfer order for the item to be picked up from one of the locations in the example db, where the item is present in great number, and to be sent to the new location. In the Transfer-from tab just below the Lines section of the transfer order the Shipment Date is 5 Feb with the Shipping Time of 1D, one day, and the Receipt Date on 6 Feb in the Transef-to section, just below the Transfer-from one.

Next thing I released both the sales and the transfer order.

After adding the proper line about AMARILLO in the Edit - Inventory Posting Setup window I was able to post the sales order by hitting the Post... button in its Home tab, in the ribbon.

But when I tried to post the transfer order by hitting the Post... button in its Home tab, in the ribbon, I got the error message 'There is nothing to post', and I have no clue as how to overcome it.

What settings are lacking in my little test ? 

Is it something like the Inventory Posting Setup that I should fill in in order to post the transfer order, or what else ?

As always, I thank you very much in advance for all the advice you will be able to give me on this.

Thank you.

                               Raoul Bertorello

Reply
Andrey Baludin responded on 5 Feb 2018 5:54 AM
My Badges
Verified Answer

Fill "Qty. to Ship" and "Qty. to Receive" fields in transfer order lines. (Set the quantity of items which you want to ship and receive).

Reply
Raoul Bertorello responded on 5 Feb 2018 7:48 AM
My Badges

Hi Andrey.

Thank you very much for your reply.

I'm afraid my knowledge is limited here, for, when I type a number in the 'Qty. to Ship' field, a message warning 'Warehouse Shipment is required for Line No. = 10000' appears at the top of the transfer order window, and if I type a number in the 'Qty. to Receive' field two messages stating respectively 'Warehouse Receive is required for Line No. = 10000 . The entered information may be disregarded by warehouse operations' and 'No items are currently in transit' show too.
Where do I find these 'Warehouse Shipment' and 'Warehouse Receive' fields ? I have no clue.
Searching for them, for example I hit the 'Whse. Shipments' button in the NAVIGATE tab on the ribbon of the transfer order window and the following window opens ... :

... , where it seems no information is lacking, and if I hit the Show Source Document Line button in the HOME tab at the top of the window above, it shows ... :

... , where it seems no information is lacking either.

Where can I find the fields warned about by the previous messages ?

Thank you very much in advance for the answer.

                                     Raoul Bertorello

Reply
Andrey Baludin responded on 5 Feb 2018 7:56 AM
My Badges
Verified Answer

Open your transfer order, click Actions - > Create Whse. Shipment.

Then open created shipment and put Qty. to Ship there. After that - post shipment.

Then Create whse. receipt the same way and post it.

After all items will be shipped and received - transfer order should disappear.

Another way is open Location card and remove there marks "Require Shipment" and "Require receipt". this way shipments and receipts will be created automatically in the moment of transfer order posting.

Reply
Raoul Bertorello responded on 5 Feb 2018 8:39 AM
My Badges

Hi Andrey.

If I hit the 'Create Whse. Shipment' button the brief 'There are no Warehouse Shipment Lines created' message shows, and likewise if I hit the 'Create Whse. Receipt' the brief 'There are no Warehouse Receipt Lines created' message shows too. And they are so laconic that I don't know what to do then.

But unticking the 'Require Receive' and the 'Require Shipment' check boxes and then hitting the Post... button in the transfer order window, saving and then going back to hit the Post... button in the transfer order window doesn't solve the situation: the 'There is nothing to post' message pops up again.

Please, tell me anything that comes to your mind, and thank you very much.

                         Raoul Bertorello

Reply
Andrey Baludin responded on 5 Feb 2018 8:47 AM
My Badges
Verified Answer

1. Have you release the transfer? Push Release button before creating shipment. Receipt can't be created before shipment will be posted.

2. if you removed Require Shipment and require receipt marks - you need to set Qty. to ship and Qty to receive in transfer order lines.

Reply
Raoul Bertorello responded on 5 Feb 2018 9:15 AM
My Badges

Yes Andrey, it doesn't post whether the transfer order is released or still open and the two marks are kept or removed (4 cases possible tested) with the two quantities in the Lines section left null.

And in all the four cases above, if I try to fill in the two quantity fields in the Lines section, then the warnings about Line No. = 10000 appear, preventing me from going any further.

Reply
Robertas Rackauskas responded on 11 Feb 2018 3:41 AM
My Badges
Verified Answer

Hi Raoul, what is the setting of the Transfer-From location? Does it use directed picks, or bins, etc? The setting of the location actually drives the process of shipment (in your case transfer shipment) and might require warehouse shipment as well as warehouse pick.

Robertas

Reply
Raoul Bertorello responded on 13 Feb 2018 2:31 AM
My Badges

Hi Robertas.

Thank you for taking part into this conversation.

First a piece of news about a change I made that could relate to some sort of evolution in the problem nature I meet: I added my Navision profile to the Magazzino (it stands for Warehouse) user group, that makes me a warehouse employee. I don't understand clearly if it has anything to spare with the evolution I point out below, as I was already a SUPER user in Navision, but I guess it could be.

Anyway I'll make you a recap of another Transfer Order that runs into a new sort of problem from the one described in the previous exchanges with Andrey.

In the General tab the Transfer-from Code is Azul (it's Spanish for Blue) and the Transfer-from Bin Code is A1. Both of these are Cronus example db settings that come already configured with Navision; I didn't change any of them and I used that bin in that location to move 150 pieces of item No. 70003 which is plenty of over there.

Again in the General tab I set the Transfer-to Code to Amarillo (it stands for Yellow) and Transfer-to Bin Code to AMAR-001. Both of these didn't exist in my Cronus before, I just made them brand new on purpose to use exactly in this transfer order.

I chose In-transit Code as inbound logistics and Posting Date as 12/2/18, because this transfer order is meant to refurbish Amarillo with that item quantity that shows in a brand new Sales Order filled in on that same date, when the system realizes Amarillo doesn't stock that item.

Back to the transfer order, its Transfer-from and Transfer-to tabs are automatically filled in with the information about Azul and Amarillo locations, once they are chosen in the General tab. The only things I set here are the Shipment Date in the Tranfer-from tab to 13/2/18, the Shipping Agent Code to inbound logistics again and the Shipping Agent Service Code to next day, so that the dates of 13/2/18 and 14/2/18 (the day the Sales Order is supposed to take place) reflect upon those in the single row in the Lines section.

That one line in the transfer order indexes 150 items of that kind in the Quantity field and now if I release the transfer order, without trying to fill in any of the Qty. to Ship and Qty. to Receive field, and I hit the Create Whse. Shipment button it opens an Edit - Warehouse Shipment card completely empty. Just blank. Maybe because of the empty Qty. to Ship and Qty. to Receive fields, yet at least now the warehouse shipment creation seems to happen succesfully. Even though it's a fake one because, as I wrote, the whse. shpt. card hasn't got a No. either.

Robertas, Andrey, if you have the time and the patience to write down anything, even something you have already written, that you think is what prevents my transfer order from finishing properly, please, do it and I promise I'll use it to correct my procedure as soon as I can.

Thank you both very, very much.

In the meanwhile, because I'm growing more and more certain you have already tried to suggest me what's already clear and working to you, I'll mark as a correct answer both of your contributions so far - hoping this forum system lets me do it, and it does not record only one of my marks.

                                                                                 Raoul Bertorello

Reply
Andrey Baludin responded on 13 Feb 2018 3:24 AM
My Badges
Verified Answer

Hi Raoul,

warehouse shipment card is totally blank because of you need to be a Warehouse Employee of Transfer-from location. I recommend you to open Warehouse employee page and create a record with your ID for each warehouse  (at least for Azul and Amarillo). So you can see all shipments and receives for this locations.

Reply
Raoul Bertorello responded on 13 Feb 2018 9:14 AM
My Badges

Ok, Andrey, I'll set myself as an employee in all these locations and then I'll redo my test on transfer orders from scratch.

Thank you vey much.

                          Raoul Bertorello

Reply
Andrey Baludin responded on 5 Feb 2018 5:54 AM
My Badges
Verified Answer

Fill "Qty. to Ship" and "Qty. to Receive" fields in transfer order lines. (Set the quantity of items which you want to ship and receive).

Reply
Andrey Baludin responded on 5 Feb 2018 7:56 AM
My Badges
Verified Answer

Open your transfer order, click Actions - > Create Whse. Shipment.

Then open created shipment and put Qty. to Ship there. After that - post shipment.

Then Create whse. receipt the same way and post it.

After all items will be shipped and received - transfer order should disappear.

Another way is open Location card and remove there marks "Require Shipment" and "Require receipt". this way shipments and receipts will be created automatically in the moment of transfer order posting.

Reply
Andrey Baludin responded on 5 Feb 2018 8:47 AM
My Badges
Verified Answer

1. Have you release the transfer? Push Release button before creating shipment. Receipt can't be created before shipment will be posted.

2. if you removed Require Shipment and require receipt marks - you need to set Qty. to ship and Qty to receive in transfer order lines.

Reply
Robertas Rackauskas responded on 11 Feb 2018 3:41 AM
My Badges
Verified Answer

Hi Raoul, what is the setting of the Transfer-From location? Does it use directed picks, or bins, etc? The setting of the location actually drives the process of shipment (in your case transfer shipment) and might require warehouse shipment as well as warehouse pick.

Robertas

Reply
Andrey Baludin responded on 13 Feb 2018 3:24 AM
My Badges
Verified Answer

Hi Raoul,

warehouse shipment card is totally blank because of you need to be a Warehouse Employee of Transfer-from location. I recommend you to open Warehouse employee page and create a record with your ID for each warehouse  (at least for Azul and Amarillo). So you can see all shipments and receives for this locations.

Reply

SBX - Two Col Forum

SBX - Migrated JS