SBX - Search With Button

SBX - Forum Post Title

Dynamics NAV 5.0 / Vista /Error 1935

Microsoft Dynamics NAV Forum

David Mapes asked a question on 17 Nov 2008 8:17 AM

Question Status

Unanswered

I'm hoping someone here can help me as I'm completely stuck on this.

I'm upgrading our accounts department from their 5 year old XP machines to new Vista 32 bit (Vista Business) machines from Dell.  Each machine is exactly the same spec, same hardware, same configuration.  When installing Dynamics NAV 5.0 using the CSideClient file I received an error message on the second machine I was working on.  The error was as follows:

Error 1935: An error occured during the installation of assembly component
{98CB24AD-52FB-DB5F-S01F-C8B3B9A1E18E}
HRESULT: 0x800736CC

After a few hours of trying I gave up for the day.  I then gave it another go today, after performing a system restore back to factory default settings.  The machine was then joined to the domain and the first installation I did, before any updates were installed, was of Dynamics. The same error occured.

The user has a roaming profile, so I alter that to a local profile and tried again, same error.

I eventually gave up on that machine, put the first machine live which worked, and started to configure two more.  Both machines received the same errors.

Having looked online, things pointed to a .net problem.  The suggested fix was to uninstall and re-install, but Vista Business comes with .net 2 installed as part of the OS.  I downloaded a .netfix form Microsoft's TechNet under another page on this Dynamics installation issue.  That file ran but made no difference.

My Dynamics support company have suggested that it's a .net issue and to uninstall / re-install, though I've not found a way of doing that on Vista (as it comes installed as part of the OS).  The only other thing they have suggested is that the machine may have a version of .net which is too new for Dynamics NAV 5.0 (SP1).  However my laptop, vista 32, has .net 3 installed and is happy running Dynamcs.

We have 10 licences, 9 in use, so I was wondering if it may be that the installation is someone using a licence, and not releasing it? It's a bit of a longshot, but I', currently unable to install Dynamics on any of the new machines.

Any help is welcome.

Reply
Diogoma responded on 17 Nov 2008 8:35 AM

 Hello there,

Sorry, but this reply is not the answer for this problem, i am only replying because I have exactly the same problem within a customer installation for training proposes today. I installed in my vista business PC some time ago, and I didn't have any problems concerning this particular issue. I suspect, that has to be related with any changes concerning Vista (services packs perhaps), because before didn't occur this error.

Regards

DMA

Reply
DaveT responded on 17 Nov 2008 1:14 PM
My Badges

Hi,

You need to install Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) first here the link

http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en

Reply
David Mapes responded on 18 Nov 2008 12:53 AM

That worked for me.

 It's odd, of the two PCs I was working on (well three), one worked straight away, one worked after I upgraded the .net framework to 3.5 and the other only worked after I installed the c++ link from DaveT's post.

 Thank you for the response, I can finally finish building these machines, and update my Dynamics installation notes.

Reply
DaveT responded on 18 Nov 2008 1:27 AM
My Badges

Hi David,

Yes there are a lot of component that can affect this and it depends on the build of the machine.

 

Glad to Help.

Reply

SBX - Two Col Forum

SBX - Migrated JS