Connection error when processing Credit Cards

Question Status

Suggested Answer
David Anderson asked a question on 11 Oct 2016 2:30 PM

A merchant is getting the following error when trying to process a credit card: "Connection Error: a network connection failed. Make sure you have a network or internet connection."

This error started happening last Saturday morning, Oct 8th.

We have checked the computer's date and it is correct. They can get to internet sites through their browser.

'Their Credit Gateway URL is:

ssl1.tsysacquiring.net

We have also tried:

ssl1.tsysacquiring.net/scripts/gateway.dll?transact

httpstxns.secureexchange.net

https://txns.secureexchange.net

and they all give the same error message.

They are using Windows 7, RMS version 2.0.0126, and their processor company is Transfirst.

Any help would greatly be appreciated.

Thanks, David

Reply
Suggested Answer
Scott Wardzinski responded on 19 Oct 2016 4:11 PM

Hello David,

Thank you for your question.

Check the URL. According to TSYS, it should be as follows:

ssl1.tsysacquiring.net/scripts/gateway.dll?Transact

For some reason, having a lower case t in Transact is causing issues.

Thank you,

Scott Wardzinski

Microsoft Dynamics RMS & POS Support Engineer

ssl1.tsysacquiring.net/scripts/gateway.dll?transact

Reply
David Anderson responded on 23 Oct 2016 11:07 PM

We finally found out that there was a firewall blocking the connection to the credit card gateway.

We figured this out by doing the DOS prompt command:

tracert ssl1.tsysacquiring.net

and only got Request Timed Out messages.

Then we did the same

tracert ssl1.tsysacquiring.net

on another computer and got positive results, which told us there was a firewall issue.

Another test we did was entering the merchants EDC info (Merchant ID, BIN #, etc.) into my home computer's RMS setup (just using my RMSSample database). Then I made a credit card transaction. It went through which told us there was nothing wrong with the EDC info that we had typed in.

Reply
Alejandro Giraldo responded on 25 Apr 2018 12:31 PM

I am having a similar issue with one of my customers,  but strangely it is only happening sometimes, they swipe a card once, twice, and sometimes it goes through after the 4th attempt.

Never had this issue before, but I am completely unaware of what can be causing this, no settings have been changed in the computers, in the last 3 years, and the issue just arose a couple of days ago.

Any suggestion on how to ping point this problem?

Reply
David Anderson responded on 25 Apr 2018 1:12 PM

2 merchants several days ago started to have to swipe their cards 2 or 3 times for cards to go through. They are using RMS 1.2 with Windows XP and using the gateway:

ssl1.tsysacquiring.net/scripts/gateway.dll?Transact

We are in the process of upgrading their systems to RMS 2.0 with Windows 7 and will see if that fixes it. If not, we are guessing it is an issue with tsys and will switch to Vantiv or Heartland.

Reply
Alejandro Giraldo responded on 25 Apr 2018 4:33 PM

My customer is using Win 7 (POS Ready 7) and RMS v 2.0.1004, using the same gateway, I am guessing it is a TSYS issue, prob enforcing EMV compliance

Reply
David Anderson responded on 25 Apr 2018 5:18 PM

If that is the case, then tsys needs to get its act together and make it so it will work with RMS using EMV chip terminals. From what I have been told, tsys will only work with EMV chip terminals if the merchants purchase RMH.

Reply
David Anderson responded on 2 May 2018 7:25 PM

The problem of having to swipe credit cards 2 or 3 times using tsys has been resolved by upgrading from Windows XP to Windows 7. Apparently tsys requires the operating system to have at least TLS 1.1 and Windows XP only allows TLS 1.0.

Reply
Andreaknits responded on 9 May 2018 9:37 AM

I am having the same problem and I am using Windows 7 with POS Dynamics 2009.  I have learned from Tsys that it was due to their changes.  (a "poodle issue") I was told to update my POS which I am looking to do anyway but they could not help resolve the problem in the interim.   Please let me know if a patch is out there.  Thanks.

Reply
David Anderson responded on 9 May 2018 11:48 AM

The RMS version that we are using is: 2.0.1007.

Reply
Suggested Answer
Scott Wardzinski responded on 19 Oct 2016 4:11 PM

Hello David,

Thank you for your question.

Check the URL. According to TSYS, it should be as follows:

ssl1.tsysacquiring.net/scripts/gateway.dll?Transact

For some reason, having a lower case t in Transact is causing issues.

Thank you,

Scott Wardzinski

Microsoft Dynamics RMS & POS Support Engineer

ssl1.tsysacquiring.net/scripts/gateway.dll?transact

Reply