SBX - Search With Button

SBX - Forum Post Title

connection to socket unsuccessful: message timeout

Microsoft Dynamics RMS Forum

tlbader4 asked a question on 1 Sep 2018 9:10 AM

Question Status

Unanswered

I am on the server computer. All ip addresses match(static IP). I'm connecting thru a vpn which we have been using for three years now. Worked up to Aug 28th. I seen a message when connecting to Hq Server that the firewall is blocking some of it.  I turned the firewall off but it still doesn't connect.  I have read multiple forums and tried all they suggested but still can't connect.  .Please let me know what info you would need to correct this issue. 

Reply
Aadeel Singapuri responded on 2 Sep 2018 6:28 AM

Hi tlbader4,

Please check other computers on same network are able to connect to HQ? or just one with vpn user is facing error?

Regards,

Aadeel S. Puri

Reply
tlbader4 responded on 3 Sep 2018 12:39 PM

I can connect within the same network.  The router thru vpn is assigning ip addresses to the vpn connection but I still can't connect error.

Reply
Aadeel Singapuri responded on 3 Sep 2018 2:27 PM

Can you able to ping HQ server local ip after connecting thru vpn?

Reply
Aadeel Singapuri responded on 3 Sep 2018 2:35 PM

Are you using windows default vpn server? If yes check subnet or vpn settings of vpn server.

Reply
tlbader4 responded on 4 Sep 2018 10:33 AM

ping results to requested timeout

I am connecting from our whse to store after connecting the whatsmyip changes to the static ip for the main store.  which is routed to the server computer.  This has been working for 3 yrs. The vpn log show the connection and changing the (whse)static ip to 192.168.1.xxx. So I don't believe this is a vpn router issue but I could be wrong. 

Reply
Aadeel Singapuri responded on 4 Sep 2018 11:46 AM

Anything can happen when it comes to fault. Your PC must be able to ping HQ Server in order to make it work. Try changing your PC ip allocation.

After connecting to VPN your PC should act like a PC that is connected to LAN.

Otherwise we can set remote desktop session to let me check in person.

Reply
tlbader4 responded on 4 Sep 2018 1:01 PM

I changed the cisco router to stop blocking wan request and I can ping the store ip. Once I connect to the vpn from the whse. I did a whatsmyipaddress.  It showed the static ip for the store as the public ip and and an internal ip address as local.  Router shows the connection on the PPTP server with Remote Address and PPTP IP Address as the same as whatsmyipaddress.

Reply
Aadeel Singapuri responded on 4 Sep 2018 1:20 PM

try disable your pc firewall. may your outbound rules are preventing.

also use utility called nmap. It can scan ports opened of target host. use local ip for port scanning. if it shows you sql port open on host it means your pc is reachable to hq sql host then your rms is somehow needs re installation or may be another issue..

Reply
tlbader4 responded on 6 Sep 2018 4:48 PM

Firewall on both machines are disabled.  I noticed two certificates expired so I install new ones but the old ones are still listed do they need to be deleted before the new ones will be activated?  So I don't know if they are making a difference or not.  The VPN to Router is connecting but be on that I don't know if it's connecting.  I tried mapping a network drive  on the client computer to the server computer. I get windows cannot access error.  

Reply

SBX - Two Col Forum

SBX - Migrated JS