Management Reporter Configuration Console has stopped working

Question Status

Verified
Kim Damazo asked a question on 22 Sep 2015 4:24 PM

I recently upgrade an SL 2015 CU1 site to Management Reporter CU13.  Everything was cool for a few days until yesterday the Configuration Console wouldn't start with the following dialog:

This is a Windows 2012 server meeting the System Requirements and I'm logged in as a Domain Admin with appropriate SL credentials.

The Application event entry for the error is:

System.Diagnostics.Eventing.Reader.EventLogException: The array bounds are invalid at System.Diagnostics.Eventing.Reader.EventLogException.Throw(Int32 errorCode) at System.Diagnostics.Eventing.Reader.EventLogReader.GetNextBatch(TimeSpan ts) at System.Diagnostics.Eventing.Reader.EventLogReader.ReadEvent(TimeSpan timeout) at Microsoft.Dynamics.Performance.Deployment.Reporting.ServiceLoggingViewModel.<.ctor>b__1(Object doesntMatter) at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch()

If anyone has insight to resolve this error I'd be grateful for your assistance.

Reply
MonacoGP responded on 13 Nov 2015 12:30 PM

OK, I justed tried running CU12 and it installed successfully, able to run Configuration Console.

So issue is somehow related to CU13 installer which I have re-downloaded and tried without success.

Reply
Verified Answer
Mötz Jensen responded on 19 Nov 2015 8:32 AM

Hi Guys,

I just ran into the same problem / issue with Management Reporter 2012 CU 13 as MonacoGP.

The Server component of Management Reporter 2012 CU 13 (MR2012-CU13) installed like a charm. I installed the application and processing service with very little effort. I now wanted to implement my integration for the AX 2012 platform but I got some errors.

I deepdived into some troubleshooting and somewere along the way the MR2012-CU13 installation broke. I'm seeing the excact same thing as MonacoGP:

  • Full uninstall of MR2012-CU13
  • Reboot server
  • Install the Server component of MR2012-CU13
  • Start the Configuration Console and receive the famuse error

  • Look into the Application Event Viewer log and find the following error message:

....
System.Xml.XmlException: Unexpected end of file.
at System.Xml.EncodingStreamWrapper.ReadBOMEncoding(Boolean notOutOfBand)
at System.Xml.EncodingStreamWrapper..ctor(Stream stream, Encoding encoding)
....

  • Did a full uninstall of MR2012-CU13
  • Reboot server
  • Install the Server component of MR2012-CU12 this time
  • Start the Configuration Console without any errors

This got me curious and I did some reverseengineering and threw all my effort into to finding the problem. Fast forward 5 hours and I found that the following scenario is what MonacoGP and I'm facing:

  • When starting the Configuration Console of MR2012-CU13 it loads the basic configuration into memory. When you exits the program, the configuration is written to disk at this location:

C:\ProgramData\IsolatedStorage\XXXX.YYYY\ZZZZ.WWWW\Publisher.XXYYZZWW\AssemFiles\DeploymentContext.txt

  • The next time you start the Configuration Console of MR2012-CU13 it reads the file and starts the program.
  • If the file is EMPTY - then MR2012-CU13 will fail with the above error message.

Delete the file and MR2012-CU13 will load the configuration into memory once again and save it when you exit the program.

Try to clear the file on a MR2012-CU13 installation and see for you self that it breaks down. Delete the file and start the Configuration Console again and exit it right away. Now the file is written to disk containing the need configuration for your installation.

TL;DR:

The Configuration Console program in MR2012-CU13 fails when the file:

C:\ProgramData\IsolatedStorage\XXXX.YYYY\ZZZZ.WWWW\Publisher.XXYYZZWW\AssemFiles\DeploymentContext.txt

is empty. 

Just delete the file and start the Configuration Console again.

Reply
Daniel Underwood responded on 9 Jan 2016 12:09 PM

You absolutely legend, that fixed my problem!

Reply
Mötz Jensen responded on 10 Jan 2016 1:44 PM

@Daniel

I sure hope you didn't waste to much time on that little bug :o)

Reply
Ganesan Natarajan responded on 16 Oct 2017 2:46 AM

Thank you! Mötz Jensen for saving my day..!

Thanks,

Ganesan

Reply
Mötz Jensen responded on 16 Oct 2017 3:35 AM

I hope that my explanation towards what goes wrong helped you work around the little bug Ganesan Natarajan.

Have a nice day :)

Reply
Joseph Guyton responded on 6 Apr 2018 1:46 PM

winner winner, chicken dinner.

Thanks!

Reply
Mötz Jensen responded on 6 Apr 2018 1:53 PM

I hope that means it worked for you as well Joseph Guyton? :)

Reply
Silvano responded on 10 May 2018 9:43 AM

hello Motz

i have the exact same issue, and i am trying to follow your instructions but i can't find any folder called "Programdata"

Reply
Mötz Jensen responded on 10 May 2018 11:17 AM

Hi Silvano

The ProgramData folder is a hidden system folder on your C drive. Please see this link for more information:

https://www.howtogeek.com/278562/what-is-the-programdata-folder-in-windows/

Here is how you configure your Windows to show the hidden files and folders:

https://www.howtogeek.com/howto/windows-vista/show-hidden-files-and-folders-in-windows-vista/

But - you actually don't need to do that. You can use the "run" from your Windows Start menu or simply paste the C:\ProgramData path into your File Explorer. Please see pictures below.

Let me know if that helps you on your way or not.

Reply
Verified Answer
Mötz Jensen responded on 19 Nov 2015 8:32 AM

Hi Guys,

I just ran into the same problem / issue with Management Reporter 2012 CU 13 as MonacoGP.

The Server component of Management Reporter 2012 CU 13 (MR2012-CU13) installed like a charm. I installed the application and processing service with very little effort. I now wanted to implement my integration for the AX 2012 platform but I got some errors.

I deepdived into some troubleshooting and somewere along the way the MR2012-CU13 installation broke. I'm seeing the excact same thing as MonacoGP:

  • Full uninstall of MR2012-CU13
  • Reboot server
  • Install the Server component of MR2012-CU13
  • Start the Configuration Console and receive the famuse error

  • Look into the Application Event Viewer log and find the following error message:

....
System.Xml.XmlException: Unexpected end of file.
at System.Xml.EncodingStreamWrapper.ReadBOMEncoding(Boolean notOutOfBand)
at System.Xml.EncodingStreamWrapper..ctor(Stream stream, Encoding encoding)
....

  • Did a full uninstall of MR2012-CU13
  • Reboot server
  • Install the Server component of MR2012-CU12 this time
  • Start the Configuration Console without any errors

This got me curious and I did some reverseengineering and threw all my effort into to finding the problem. Fast forward 5 hours and I found that the following scenario is what MonacoGP and I'm facing:

  • When starting the Configuration Console of MR2012-CU13 it loads the basic configuration into memory. When you exits the program, the configuration is written to disk at this location:

C:\ProgramData\IsolatedStorage\XXXX.YYYY\ZZZZ.WWWW\Publisher.XXYYZZWW\AssemFiles\DeploymentContext.txt

  • The next time you start the Configuration Console of MR2012-CU13 it reads the file and starts the program.
  • If the file is EMPTY - then MR2012-CU13 will fail with the above error message.

Delete the file and MR2012-CU13 will load the configuration into memory once again and save it when you exit the program.

Try to clear the file on a MR2012-CU13 installation and see for you self that it breaks down. Delete the file and start the Configuration Console again and exit it right away. Now the file is written to disk containing the need configuration for your installation.

TL;DR:

The Configuration Console program in MR2012-CU13 fails when the file:

C:\ProgramData\IsolatedStorage\XXXX.YYYY\ZZZZ.WWWW\Publisher.XXYYZZWW\AssemFiles\DeploymentContext.txt

is empty. 

Just delete the file and start the Configuration Console again.

Reply