SBX - Search With Button

SBX - Forum Post Title

ROI.exe

Microsoft Dynamics SL Forum

TECH asked a question on 8 Jun 2018 8:54 AM
My Badges

Question Status

Suggested Answer

ROI.exe appears to be crashing, however Dynamics SL is not aware of this. On one workstation, multiple users cannot open report screen and any attempt to do so results in a Windows event in the application log mentioning that ROI crashed. In Dynamics SL no error message and the "Active Users" screen shows the report screen as running on the workstation; so it's a mystery. I've tried changing the printer settings, reinstalling SL on the workstation, and of course searched customer source for similar problems, but nothing.

Any suggestions?

Dynamics SL 2015 CU1 on Windows 10

Reply
David Callery responded on 14 Jun 2018 5:41 AM
My Badges

I have run into this scenario at a few customers and it has been related to inconsistent versions of Crystal.  Are their any other applications on this particular workstation that use Crystal Reports.  A common culprit is Fixed Assets from Sage as that uses Crystal 2016 but any other application could cause this.

Reply
TECH responded on 14 Jun 2018 10:25 AM
My Badges
Suggested Answer

That is actually exactly the application that was the problem, I had recently updated Sage to 2018, which is apparently incompatible with all versions of Dynamics; to fix I removed Sage, and had to remove Crystal + Dynamics and re-install the client. Glad you replied, it reminded me to post the solution.

Reply
TECH responded on 14 Jun 2018 10:25 AM
My Badges
Suggested Answer

That is actually exactly the application that was the problem, I had recently updated Sage to 2018, which is apparently incompatible with all versions of Dynamics; to fix I removed Sage, and had to remove Crystal + Dynamics and re-install the client. Glad you replied, it reminded me to post the solution.

Reply

SBX - Two Col Forum

SBX - Migrated JS