SBX - Search With Button

SBX - Forum Post Title

Management Reporter "An unknown error has occurred"

Microsoft Dynamics SL Forum

Igor_CF asked a question on 8 Jun 2018 4:56 PM
My Badges

Question Status

Suggested Answer

Hello!

We have a strange problem with one of balance sheet reports. All of a sudden it stopped working, giving us "An unknown error has occurred while processing report".

I created a copy of the row definition and started deleting row by row and running the report. At some point the report started working. Then I added last deleted row and report stopped working. Next, on the row that "made report fail" I changed account number to one I already had in rows above, and report run fine.

Then I created clean row definition and added one row with account that made report fail and report ran fine. I added second row with another account and report failed. 

After all experiments here is what I got: for example, account 10000 thru 13000 can be combined on the report. Once I added 13100 and later accounts, report fails, but if I have 13100 account only on the report, it runs fine. Never saw something like this before. 

Does anyone has any idea?

SL version 2011 (8.10.30917.00), MR version 2.0.1700.66

Reply
Carolyn Froton responded on 11 Jun 2018 11:52 AM
My Badges
Suggested Answer

Igor,

Thank you for posting your question to the forum. The "An unknown error has occurred while processing a report" message in MR is a generic error that could point to any number of issues.

Here are a few links to other reports of this error in MR. Please note, even though your using MR with SL, MR runs with GP and AX. Many of the issues in MR are seen across these other ERP solutions.

    community.dynamics.com/.../management-reporter-an-unknown-error-has-occurred

    www.azurecurve.co.uk/.../management-reporter-error-an-error-occurred-while-configuring-management-reporter-application-service-part-1-database-principal

    www.brittenford.com/.../how-to-find-and-fix-errors-in-management-reporter

    www.plumblineconsulting.com/report-queue-status-window-displays-an-unknown-error-has-occurred-while-processing-report-report_name-when-attempting-to-generate-a-report-after-rebuilding-the-management-reporter-data-mart

Some of these links have some good tips on finding out what the underlying issues is with your report. The last link from Plumbline Consulting notes the exact error you referenced and found restarting the 2 MR services fixed it in their instance. Could your site possibly have rebuilt their data mart and note realized they needed to restart the services also?

I hope one of these helps.

Thank you,

Carolyn

MSDSL Technical Support

Reply
Trenton Evenson responded on 12 Jun 2018 11:54 AM
My Badges

The version of Management Reporter that is being ran is almost 7 years old.

I would recommend updating to the current version: mbs.microsoft.com/.../MROverview

Reply
Carolyn Froton responded on 11 Jun 2018 11:52 AM
My Badges
Suggested Answer

Igor,

Thank you for posting your question to the forum. The "An unknown error has occurred while processing a report" message in MR is a generic error that could point to any number of issues.

Here are a few links to other reports of this error in MR. Please note, even though your using MR with SL, MR runs with GP and AX. Many of the issues in MR are seen across these other ERP solutions.

    community.dynamics.com/.../management-reporter-an-unknown-error-has-occurred

    www.azurecurve.co.uk/.../management-reporter-error-an-error-occurred-while-configuring-management-reporter-application-service-part-1-database-principal

    www.brittenford.com/.../how-to-find-and-fix-errors-in-management-reporter

    www.plumblineconsulting.com/report-queue-status-window-displays-an-unknown-error-has-occurred-while-processing-report-report_name-when-attempting-to-generate-a-report-after-rebuilding-the-management-reporter-data-mart

Some of these links have some good tips on finding out what the underlying issues is with your report. The last link from Plumbline Consulting notes the exact error you referenced and found restarting the 2 MR services fixed it in their instance. Could your site possibly have rebuilt their data mart and note realized they needed to restart the services also?

I hope one of these helps.

Thank you,

Carolyn

MSDSL Technical Support

Reply

SBX - Two Col Forum

SBX - Migrated JS