SBX - Search With Button

SBX - Forum Post Title

SL 2015 CU2 ASN/Pack Indicator Label Issue

Microsoft Dynamics SL Forum

Mark E asked a question on 14 Mar 2019 11:57 AM
My Badges

Question Status

Unanswered

We have been successfully printing labels for Walmart for some time.  Walmart recently is requiring setup of ASN/856.  As part of their requirements, they mandate sending the GTIN-14 value as the Universal Container Code (UCC).  We determined that in order to get this value on the Outbound 856, we need to setup Pack Indicators for the products in the 50.201.00 screen.  Doing this does create the correct value on the Outbound 856, but also creates Container Label printing errors.  The 50.405.00 throws an error (5040500.EXE has stopped working), and the SOL1.TXT file that gets created is empty (no label data).  This affects all labels, not just Walmart.  When I remove the Pack Indicator record, the labels work again.

Reply
Mark E responded on 18 Mar 2019 10:27 AM
My Badges

Bumping....

Reply
Carolyn Froton responded on 18 Mar 2019 3:52 PM
My Badges

Mark,

Thank you for posting to the forum. I looked in our bug database and have not seen this issue reported to support. When you setup the Pack Indicator record are you using Global or Item Specific?

I did find a prior issue where the SOL1.TXT was blank, but it was fixed back in 7.x. It does make me wonder if there is something needed for the 5040500.INI to get this to pull in for you.

I am guessing the "5040500.EXE has stopped working" is noting APPCRASH. Is  this correct? Often when we see this there is a value being passed the process does not like.

I hope that helps. If you can share more about your setup, I am happy to try to see what i can find on our end.

Thank you,

Carolyn

MSDSL Technical Support

Reply
Mark E responded on 18 Mar 2019 4:15 PM
My Badges

Thanks for the reply.  We tried both options, Global and Item Specific.  Tried each separately, and also together.  No option works.  Below are the snapshots.  I'm trying more testing of different scenarios (open/closed Shippers, etc.).

Reply
Mark E responded on 18 Mar 2019 7:23 PM
My Badges

In some cases, the file is blank.  In others, the file gets partially created and process crashes.  Some .txt files actually get fully created and labels print.  I am trying to figure out the reason for the differences.  If I was able to debug the process, that would help.  If we don't use the Pack Indicator, the files always gets created correctly.

Reply

SBX - Two Col Forum

SBX - Migrated JS