SBX - Search With Button

SBX - Forum Post Title

Web Apps error: Item not found

Microsoft Dynamics SL Forum

Omarchris asked a question on 23 Apr 2019 6:28 PM

Question Status

Suggested Answer

I am using Web Apps 2015 for Dynamics sl 2015. Everytime I try to enter a item request I get the message shown in the picture above. Note inventory is setup and I can make the request in dynamics using the same Inventory ID, so the issue is on Web apps and and I am not sure what the issue is. also I can approve requests made in dynamics item request from web apps so that underline that the issue is with web app. Have anyone had this iisue and can assist me with how to solve it?

Reply
Carolyn Froton responded on 25 Apr 2019 4:58 PM
My Badges

Hello OmarChris,

You get an event log, its default location is : C:\ProgramData\Microsoft Dynamics SL

There are two directories, one for the service one for the client and a new one gets created each day. It normally gives a clearer error.

But with that said, it was a bug in an older version and the latest version of 2015 CU2 webapps is available

Go to this location for all the latest and greatest information and download links for Dynamics SL

mbs.microsoft.com/.../SLDirectory

this looks to be bug 38796: Item not found please re-enter RQITEMREQDET.INVENTORYID: saving an item request in webapps using a Goods for..Purchase For , when Inventory is not installed.

Thank you

Jana

Reply
Suggested Answer

Hi,

Access rights issue. Check the user id is available in the table (SIUserAppAuth). If the user is not on the table you need to insert the record to resolve this issue.

Thanks,

Ajit Kannan

Reply
Suggested Answer

Hi,

Access rights issue. Check the user id is available in the table (SIUserAppAuth). If the user is not on the table you need to insert the record to resolve this issue.

Thanks,

Ajit Kannan

Reply

SBX - Two Col Forum

SBX - Migrated JS