AX Retail replication problems

This question is answered

Hello,

we have an issue with AX 2012 Retail. There is only one POS. Now we want to replicate the data from AX to the POS by using the N-Jobs. RetailStoreConnect works fine. The incoming and outgoing messages are processed correctly. The problem is, that no items and customers are replicated. Tables like HcmWorker or EcoResProduct (where data is not saved per company) are replicated completely.

Does anybody have an idea about what could be wrong in our configuration based on these facts?

Thank you very much.

Best regards,

Sven

Verified Answer
  • Is the distribution location pointing to a store/channel that has data for that company? If you go to Distribution Locations and find the location you are using, the Channel should point to the store who's data you want to push. Go to that store and find out what company it is in and confirm there is data in that company.

  • Assuming the distibution locations are correct as above

    1 how have you setup up customer EG with specific address books?

    Have you assigned a customer address book to the store?

    Try creating a simple assortment and add that to your store

    Then replicate again

All Replies
  • Is the distribution location pointing to a store/channel that has data for that company? If you go to Distribution Locations and find the location you are using, the Channel should point to the store who's data you want to push. Go to that store and find out what company it is in and confirm there is data in that company.

  • Assuming the distibution locations are correct as above

    1 how have you setup up customer EG with specific address books?

    Have you assigned a customer address book to the store?

    Try creating a simple assortment and add that to your store

    Then replicate again

  • Thank you both, that helped!