Question Status

Suggested Answer
Sebastian Cuartas asked a question on 25 Jun 2013 1:08 PM

hello guys, i just installed a VM with AX 2012 R2. I need to have my client running with Spanish, but when i change it, it doesn´t change and shows me English forms.

Anyone who could help me would be very appreciated!! 

thanks!

Reply
Suggested Answer
Francisco Silva responded on 29 Oct 2013 4:57 AM

i know that this question is a little obvious but i have to ask!!!

Did you guys verified if the AX license file have the key for your own language?

 

While installing AX yourselfs did you enabled the "Foundation Labels" option?

Dont forget to mark this as answer!

Francisco Silva | | http://fsilvajunior.blogspot.com.br

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
Suggested Answer
Sql Server DBA responded on 3 Jan 2014 1:42 AM

The solution to this is to install "Foundation Labels" - Just use Powershell to install the model and the Language is correct.

Reply
Dominic Lee responded on 25 Jun 2013 8:27 PM

Hi,

- Double check you changed the user "Language" setting (instead of "Alternate Help Language") to es/es-mx

- Restart the client after the change.

Does it still show English?

kind regards,

Dominic Lee

My blog | PBC

This forum post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

Reply
Pavel C. Ondreicsik responded on 26 Jun 2013 2:34 AM

Hi,

if you change the language and save the changes, you have to restart the client

Reply
Sebastian Cuartas responded on 26 Jun 2013 2:56 PM

yes! if i restart the client it still shows english forms.

look at this:

as you can see, the most part of the screen is in English, but at the top of the client it says Página de Area...

so, i don´t get it. I changed both of the languages options available (Language, Alternate Help Language) but it does not work.

thanks for your help!

Reply
André Arnaud de Calavon responded on 30 Jun 2013 2:30 PM

When looking at your printscreen, I can see you created a virual machine yourself. Did you install AX2012 completely?

Have you checked if the labels contains the translations of the spanish language (es and es-mx)? You can open the label editor to see if it is there.

kind regards,

André Arnaud de Calavon  |  Microsoft Dynamics AX Solution architect  |  My blog  |  My company

This post is my own opinion and does not necessarily reflect the opinion or view of my company, Microsoft, both its employees, or other MVPs.

Reply
Endriu responded on 14 Jul 2013 2:15 AM

Hello,

I have the same with polish language settings - have You resolved Your problem?

Thx in advance

Reply
Cedric P BONNOT responded on 21 Oct 2013 9:29 AM

Hello,

I also have the same issue with the french language.

Have you found any solution ?

Regards

Cédric

Reply
Suggested Answer
Francisco Silva responded on 29 Oct 2013 4:57 AM

i know that this question is a little obvious but i have to ask!!!

Did you guys verified if the AX license file have the key for your own language?

 

While installing AX yourselfs did you enabled the "Foundation Labels" option?

Dont forget to mark this as answer!

Francisco Silva | | http://fsilvajunior.blogspot.com.br

This posting is provided "AS IS" with no warranties, and confers no rights.

Reply
THM responded on 5 Nov 2013 12:02 PM

AX2012 read the language id from the client system not based on the user setup. In order to read the language id based on the user setup, we need to make code change in getSystemLanguageId() method of SystemParameters table.

Change the following line of code:

systemLanguageId    = SystemParameters::find().SystemLanguageId;

To

systemLanguageId = infolog.language();

Regards

Reply
Suggested Answer
Sql Server DBA responded on 3 Jan 2014 1:42 AM

The solution to this is to install "Foundation Labels" - Just use Powershell to install the model and the Language is correct.

Reply